Dynamic DNS update (HE ipv6) doesn't work



  • I have a second WAN that gets ipv6 froma 6rd tunnel. I want to register it to a AAAA record on my HE.net DNS account, but the dynamic DNS on pfsense is not working with the HE.net (v6) option. Here is the log when I force an update:

    Jul 9 20:41:48	php-fpm	78016	/services_dyndns_edit.php: Dynamic DNS (ipv6.nowayout.ca) There was an error trying to determine the public IP for interface - opt1 (vmx3 ).
    Jul 9 20:41:48	php-fpm	78016	/services_dyndns_edit.php: Dynamic DNS (ipv6.nowayout.ca): running get_failover_interface for opt1\. found vmx3
    Jul 9 20:41:48	php-fpm	78016	/services_dyndns_edit.php: Dynamic DNS: updatedns() starting
    

    the normal HE.net for IPV4 works and it updates without problems.



  • Anybody?



  • I was having trouble, but finally got it to work this way. Of course, use your own domain name and the key from the dns.he.net tool as the password.




  • Is the "LAN" interface an error in your config? You usually monitor the WAN interface or OPT1 if OPT1 is your secondary WAN connection.



  • @kpa:

    Is the "LAN" interface an error in your config? You usually monitor the WAN interface or OPT1 if OPT1 is your secondary WAN connection.

    It might be intentional. I actually do the same thing… I have two hostnames set up, one for the WAN IPv6 address and one for the LAN IPv6 address. I have smokeping set up on a VPS that pings both, so I can see if there are issues with the prefix delegation from my ISP (i.e. if WAN responds but LAN doesn't).



  • Yes, it's intentional. I'm using the "track interface" option on the LAN so that it gets its IPV6 address from the WAN. My isp uses 6rd so my wan is configured accordingly. When I used WAN for the interface in the dynamic dns settings it gave a similar error about getting the address.

    The more I think about this, the more sense it makes. With IPv6 the LAN address is the public address so the tricks we've always used to get around NAT complications are no longer needed.


Log in to reply