PPPoE not routing in 2.3.1-RELEASE-p5



  • I have 2 connections, one is currently plugged into the ISP router and thus has an RFC1918 IP statically assigned and 1 is PPPoE with a real IPv4/IPv6 address.

    If I set the PPPoE connection to the default gateway in pfSense i just get destination host unreachable on anything behind hte firewall for ipv4 traffic (Not tried v6 yet) following a reboot.

    When I first change it the traffic continues to flow over the statically assigned WAN  ::)

    Like wise if I configure the firewall to route traffic from the LAN to the PPPoE gateway it continues to flow to the other gateway instead  ???

    It's worth noting that both virtual NICS for the wan are bound to the same physical NIC atm as I'm waiting another network card (The PPPOE is being passed through the ISP router's switch to the other modem, not ideal but ok fora temporary measure)

    PfSense is running in a VM on a proxmox host, although I've been able to run the same config when testing OpnSense and the Sophos XG firewall and it's worked on both of those./

    The PPPoe interface does come up and gets the correct IP from the ISP.etc so I don't see why it's not using it.



  • Disable the negate rule in advanced seemed to fix the problem of gateways not being acknowledged in firewall rules.

    The other problem of the default gateway not working when set to the PPPoE interface looks like it may be resolved by setting the other static gateway distance to 2 (It seems ticking the default gateway box on the PPPoE gateway wasn't enough)



  • What do you mean the "static gateway distance"? There is no such field.

    The default gateway not being added is probably https://redmine.pfsense.org/issues/6495



  • Sorry it was the "Weight" in system_gateways_edit.php but that should have only affected gateway groups so might just have been a co-incidence