Binding LAN with WAN



  • hello,
    I have two Ethernet  ports. One is the Ethernet cable that has an Internet connection and hence is providing the internet connection to the system onto which pfsense is installed. While installing pfSense I assigned that interface(bfe0) to WAN. Now I have connected my other Ethernet port with my laptop via LAN cable and have configured pfSense and assigned that interface(sk0) to LAN. LAN is throwing a static IP to my laptop from the range I provided while configuring it on pfSense console.

    Now I want to access the internet on my laptop via the pfSense server.
    When I try to ping the static Ip I provided to LAN interface (sk0) from my laptop, it's pinging, but when I am trying to ping WAN (bfe0) from my laptop it's saying Host Unreachable.

    How to bind WAN(having an Internet connection) to LAN(connected to my laptop)?
    WAN ip  192.168.1.X/24(static)
    LAN ip    192.168.2.Y/24(static)

    Thanks.


  • Rebel Alliance Global Moderator

    not sure what your doing wrong but pfsense would automatically work in this fashion..  There is no "binding" of anything required.  Run through the setup.  Pfsense has wan IP and lan IP it will auto nat and away you go.

    You did not put a gateway on your lan did you?  that is not the default lan IP how did you change it from the default.  Something prob not right there.  So your saying your laptop can access the gui of pfsense using its lan IP?  What does it show for the status of your wan?

    Can pfsense ping its gateway of its wan?  Did you alter the default lan rules of any any?



  • It worked. Actually, I was not providing the DNS server to my static IP on my laptop and hence it was refusing to ping. Thanks  :)



  • One more thing. Now from my laptop I can ping LAN's ip, WAN's ip, WAN's gateway and DNS server, but I cannot ping google.com. Even from my browser I can open pfsense login portal with both the IP's (LAN and WAN), but google.com and any other website is not getting loaded.



  • I was not providing the DNS server to my static IP on my laptop and hence it was refusing to ping

    You can ping any IP address without needing DNS. So that statement only makes sense if you were trying to ping to a name.

    It sounds like you do not have DNS working, but do have IP network/routing OK.

    First try to ping and traceroute to an IP address like 8.8.8.8 that should always be reachable and respond.

    Once that is working, you know that you have internet routing working.

    Then work on why names do not work, why your DNS is not working.


  • Rebel Alliance Global Moderator

    With phil on this dns has nothing to do with ping at all..  When you say you can not ping IP, that points to you tried to ping the IP address, not resolve some name that never resolved..

    I would want to do know what he is trying to use for dns in pfsense.  It default to using unbound that would actually try to resolve.. Did you change it to the forwarder?  You have a static IP on your wan that is rfc1918 and your asking it?  Do you have the block rfc1918 set?

    Your nat device in front of pfsense could be blocking dns to the authoritative servers which is what resolver does, your isp could be doing that, etc.