Can not set Speed and Duplex for LAN - 2.3.1-RELEASE-p5 (i386)



  • Greetings,

    We are running 2.3.1-RELEASE-p5 (i386).

    Since we updated to 2.3.1-RELEASE-p5 (i386) we are unable to set our LAN interface to 100Base TX full-duplex. In the  GUI => Interfaces the LAN interface shows  1000baseT <full-duplex>, although its Speed and Duplex set to 100Base TX full-duplex. We have lots of dropped packets when the LAN interface is set at 100Base TX full-duplex making the LAN network problematic to use. We have three other interfaces/networks all successfully set to 100Base TX full-duplex.

    Could you please help with the setup to make out LAN interface use  Speed and Duplex set to 100Base TX full-duplex?

    Thank you,</full-duplex>



  • What hardware are you running this on? I had the exact same problem using an APU2 board, turns out it's a bug in the Realtek NIC driver.  No fix available currently, so I swapped it out for a unit with Intel NICs – working fine now.

    Do your interfaces show up as re0, re1, re2 etc? If so then this might be your issue...



  • Likely what luckman212 noted. Some Realtek chipsets will not disable autonegotiation.

    But what you really should do is figure out why you need to force 100 full. Someone probably did something stupid like forcing switch ports to 100 full. Or maybe using CAT5 (not 5e) cables on a gigabit network. You're working around the root problem, where you should be looking to fix it.



  • Thank you for your support! We got this from Logic Supply with Pfsense installed, its: Industrial Intel Atom Firewall with pfSense® Software, 1 x Jetway 3x 1Gb Realtek LAN Module, we see EM, and RE interfaces, clearly Realtek is in the mix.

    We will indeed look into the root cause.

    Thank you again for your support!



  • Yeah that'd probably be one of the chipsets that won't disable autonegotiation. Verify your switch ports are all set to autonegotiate, and that your cables are CAT-5e or better and aren't bad.