Cannot NAT ssh with other port than 22



  • Hello,

    I need to setup port forwarding on a couple of host for ssh protocol

    it works if I use wan_ip:22 but as I need more than one host to be accessible, I tried to setup the forwarding to wan_ip:other port
    and it does not work

    would there be any reason why ssh forwarding would be only authorized on port 22 ?

    thanks


  • LAYER 8 Global Moderator

    no clearly your doing something wrong.

    Are you trying to do wan:2222 to lan:22 or wan:2222 to lan:2222 ?  If second option then you clearly have to make sure you change the lan side box to accept ssh on other than 22.

    Did you go through the port forward troubleshooting guide?
    https://doc.pfsense.org/index.php/Port_Forward_Troubleshooting

    What port did you pick other than 22, maybe your isp is blocking it?  Maybe there is nat in front of pfsense and you different forward this other port.



  • yeah I think they only allow outgoing port 22 on my pc here, so I requested to open the other ports
    we'll see

    thanks anyways, If it is not solved that way, I'll come back :-)


Log in to reply