NUT 2.7.4 missing dependencies?



  • I have searched, I am sure it must be in here so if anyone can point me in the right direction I would be grateful, but I am getting nowhere fast with NUT.

    I have installed the sysutils package, but it seems the dependencies do not come with it.  I am new to freeBSD, so I am having trouble working out just where and how I can get NUT 2.7.4  Do I have to install this manually, and if so, do I need to build the package?  I can't seem to find any binaries … or the files to build it from for that matter.

    As I said, I am sure this is somewhere but I can't seem to find it ...



  • NUT can be added via the package manager (System / Package Manager / Available Packages). The existing pfSense NUT package does use NUT 2.7.4, however there are many drivers missing from the interface. A new pfSense package is awaiting merge.

    https://forum.pfsense.org/index.php?topic=114871.0



  • Thank you denny.  I saw that thread but was not clear how long it would be before it arrived.

    I used System / Package Manager / Available Packages, but it seems to be missing the NUT 2.7.4 dependency altogther.  I tried reinstalling, but got nowhere.  I keep getting this error msg …

    ERROR: NUT is enabled, however the service is not running! The SNMP UPS may be unreachable.

    I have tried starting it but it just keeps throwing up the same error.  I am trying to monitor an APC ups with an NMC2 card.  It is quite possible I have misconfigured something at either end, as I am in very virgin territory for me with this.  I will just remove it for now and wait for the new verision.  Good luck with it.  Thank you.