Free drive space very different between MASTER and Backup



  • Greetings,

    pfSense 2.2.6 in a CARP config.  SG units are working wonderfully except for one concern.

    Noticed that the amount of storage space available on my primary SG unit is ~30% greater then my Backup unit.  Did some digging through the file system of both units and there are MANY reasons why the PRIMARY should have less space available then the backup but the MASTER is sitting at 54% used and the backup is sitting at 88%.

    Did a df -hi from the console on the backup and it's showing:
    Filesystem                                Size    Used  Avail    Capacity iused ifree    %iused  Mounted on
    /dev/ufsid/552fe7360219b349    2.7G    2.2G    304M    88%      70k    332k  17%      /

    and on the MASTER
    Filesystem                                Size    Used    Avail  Capacity iused  ifree    %iused  Mounted on
    /dev/ufsid/552fd281b8dd9271    2.6G    1.2G    1.2G    51%      23k    378k    6%        /

    Any suggestions?  As always, thanks ahead of time for your assistance.



  • Depends on what you're running on them. Guessing you're using a package of some sort that collects data (squid cache, ntop, similar) and primarily only does so on the system with master status.



  • Thanks for posting!

    Currently:
    Package Name   Category                         Package Version
    File Manager   Utility                         0.2.2
    FTP Client Proxy   Services                         0.3
    ntopng           Network Management 0.8.2
    pfBlockerNG   Security                         2.0.6

    And those are on both units.  pfBlockerNG is syncing between the MASTER and the Backup

    I'm using Beyond Compare to do a side by side comparison of the to file systems and the MASTER is using WAY more space.

    One file that is NOT on the backup but is on the MASTER is check_reload_status.core  with a size of  9,015,296.

    Is my file system corrupt on the Backup?  Is there a way to force a fresh audit of available drive space?



  • ntopng I'm sure is the difference. The system that's backup will have very little data, the master will have much more. Sounds normal.



  • That was it!  Well, kind of.

    At one time I switched over to the backup and shortly there after I ran that ntopng.  Went into the settings and Deleted the historic data.  Spun for a long time eventually I grew impatient and went back to the dashboard and not it's dropped from 88% -> 41%.

    Curious thing is that I didn't enable the historical data to be kept.  Not sure why pressing the Delete (historical) data would have worked…

    Oh well.  It solved my problem.

    Thanks for your help!!