Erro na autenticação Squid - AD



  • Bom dia,
    Tenho o seguinte cenário: Servidor PFSense com Squid + SquidGuard Autenticando em um Windows Server 2008 R2, sem problemas até então.
    Estamos substituindo este servidor e o novo AD está configurado em outro server com Windows 2012 R2, quando configuro o Squid no novo AD não autentica e apresenta o seguinte erro no cache.log:

    basic_ldap_auth: WARNING, could not bind to binddn 'Invalid credentials'

    Quando configuro no Server 2008 volta a funcionar normalmente.



  • Tem print das configurações da integração?

    eu tenho pfsense integrado com AD no windows server 2012.

    Tem alguns topicos sobre este erro aqui no forum tbm.



  • @rvl:

    Tem print das configurações da integração?

    eu tenho pfsense integrado com AD no windows server 2012.

    Tem alguns topicos sobre este erro aqui no forum tbm.

    Oi RVL, já dei uma pesquisada nesse erro e não encontrei nada no fórum, já tentei reinstalar os serviços, reconfigurar e até já fiz uma instalação limpa do PFSense, mais não consigo fazer autenticar….
    Segue um print da Configuração:

    ![Config valu.jpg](/public/imported_attachments/1/Config valu.jpg)
    ![Config valu.jpg_thumb](/public/imported_attachments/1/Config valu.jpg_thumb)
    ![Config valu2.jpg](/public/imported_attachments/1/Config valu2.jpg)
    ![Config valu2.jpg_thumb](/public/imported_attachments/1/Config valu2.jpg_thumb)



  • Você verificou se a senha do usuário que está fazendo a autenticação no AD está correta?
    Essa senha não pode começar com número e nem caracteres especiais.



  • @RogersCrazy:

    Você verificou se a senha do usuário que está fazendo a autenticação no AD está correta?
    Essa senha não pode começar com número e nem caracteres especiais.

    ja verificou a questao da senha que RogersCrazy comentou, aparentemente tudo ok, coloca uma senha simples.



  • @rvl:

    @RogersCrazy:

    Você verificou se a senha do usuário que está fazendo a autenticação no AD está correta?
    Essa senha não pode começar com número e nem caracteres especiais.

    ja verificou a questao da senha que RogersCrazy comentou, aparentemente tudo ok, coloca uma senha simples.

    Boa tarde, já verifiquei a questão da senha também, deixei uma senha simples somente com letras e números, porém não vai da mesma forma, engraçado que quando configuro com o meu servidor de AD antigo(Com 2008R2) autentica normal =/



  • Agora adicionei o servidor AD em: System > User Manager > Authentication Servers
    Consegui adicionar o servidor e ele encontra as OUs e grupos, porém dentro do Squid não autentica :(:(
    Dúvida, tenho como usar o servidor de autenticação pra autentica o Squid?



  • Qual é a versão do seu PFSense?



  • @RogersCrazy:

    Qual é a versão do seu PFSense?

    Roger, é a 2.3.1-RELEASE-p5



  • Essa autenticação está sendo feita como? Você chegou a instalar o pf2ad?



  • Poderia verificar e postar o que aparece no log do squid?



  • Bom dia, depois de muito quebrar a cabeça descobri o problema, o mesmo estava na forma como foi configurado o AD, o campo Nome de domínio(Anterior ao Windows 2000) foi configurado com o nome diferente do próprio domínio, então o squid não conseguia autenticar.
    Segue abaixo como ficou a configuração do squid.
    Valeu pela Ajuda!!

    ![Erro Squid.JPG](/public/imported_attachments/1/Erro Squid.JPG)
    ![Erro Squid.JPG_thumb](/public/imported_attachments/1/Erro Squid.JPG_thumb)


Log in to reply