Installation on Supermicro board via SOL - Error



  • Hi
    I have assembled a pfsense machine with the below specs:
    1. supermicro A1SAI 2550F
    2. 2x8GB ECC RAM
    3. 120GB crucial SSD
    5. M-350 chassis

    I am able to log into the firmware via Serial over LAN and the firmware seems to detect all the installed hardware. However, when i try booting the memstick-serial image (burnt on a usb), the following happens:
    1. It shows me the boot option (multiuser/single user etc.,)
    2. When I choose the default multiuser, it seems to read something still syms= <hex value="">3. The screen then apparently tries to refresh but it gets stuck by the time the 'pfsense' text refreshes and the USB light stops glowing.
    4. After a while the usb light starts glowing again, but everything is stuck.

    I tried the following:
    1. used another usb stick
    2. tried the full distribution image , memstick image

    All of them end up with the same error.I have attached a screenshot of the SOL window. You can observe the partially refreshed pfsense name on the top,
    I would appreciate any help/pointers toward sorting this issue. Currently I don't have a VGA display, and depend only on SOL.

    </hex>



  • If this board is like my Supermicro X11SBA, it probably doesn't have SOL on COM1 (which is the default console used by pfSense), but on COM2. In this case you won't see any console output after the loader. You can try changing the console by entering custom boot parameters, like described in steps 6 and 7 here:

    http://www.netgate.com/docs/rcc-dff-2220/freebsd.html

    If that works, you should also add the same parameters to /boot/loader.conf.local once the installation is complete, so you can see the output of the installed pfSense.



  • Thanks for the response. The netgate document shows the port address to be "comconsole_port=0x2F8" . Is this a standard address for all COM2 ports? If not, could you please tell me how to find out the port address of my board? The firmware doesn't seem to show the address.



  • Yes, if your board uses COM2 for SOL, 0x2F8 should be correct. You can see the I/O addresses assigned to the COM ports in the BIOS under "Super IO Configuration".



  • Quick update - the config worked. Thanks. However, due to some unknown issue in the serial line, it was quite slow (i had set baud rate as 115200). I got me a serial-usb cable and things have been much better.


Log in to reply