SQUID navegar pela WAN 2.



  • Fala galera, sei que tem vários tópicos sobre isso aqui no fórum, porem não achei nada para o PFSENSE 2.3 ( que nao tem as mesmas opções no squid ).

    Meu problema é o seguinte, tenho 2 links:
    WAN 1 - Default
    WAN 2 - Proxy

    Porem, não estou conseguindo redirecionar o proxy para navegar pela WAN 2.



  • Em custom options do squid, coloque:

    tcp_outgoing_address WAN2_ADDRESS

    Veja se resolve.

    Procure sobre a tag tcp_outgoing_address do Squid, se informe sobre a sua utilidade.

    Talvez seja necessário criar regras na aba Floating, dependendo do caso.



  • Agradeço a resposta Brunok, me deu uma luz  8) 8)

    Na versao 2.3 nao tem Custom Options, porem fiz da seguinte maneira:

    Squid -> Custom ACLS (Before Auth):
    acl link2 src 192.168.0.0/24
    tcp_outgoing_address 187...215 link2

    Funcionou perfeitamente.  ;D ;D ;D

    –---

    Implementando, para quem tem na WAN com ip dinamico, pode usar no lugar do IP o nome da placa de rede, no meu caso NFE0.
    acl link2 src 192.168.0.0/24
    tcp_outgoing_address nfe0 link2

    –--

    Depois de uns teste, usando o nome da placa de rede, da erro no squidguard, tem q usar por ip mesmo, se eu achar outra alternativa, posto aqui.



  • @henriquefr said in SQUID navegar pela WAN 2.:

    tcp_outgoing_address nfe0 link2

    Fantástico! É a solução (usando pfSense 2.4). Estava brigando com regras flutuantes e NAT de saída até que achei este post. Valeu também, @brunok


Log in to reply