Upgrade 2.3.1 to 2.3.2 fails



  • Hi,

    I’ve tried to upgrade my pfSense installation from 2.3.1 to 2.3.2. After upgrading the php56-ctype package, the upgrade process stock and didn’t move forward. After waiting for 15 minutes I’ve decided to reboot and try again, but the reboot didn’t change anything.

    The update checker shows now this error: “Unable to check for updates”

    Is there any way to solve this issue and perform the upgrade?

    -Grumpel





  • Thanks. Worked very well.



  • try to upgrade from ssh option 13



  • Looks like servers are under heavy load.
    pkg: https://pkg.pfsense.org/pfSense_v2_3_2_amd64-core/All/pfSense-kernel-pfSense-2.3.2.txz: Operation timed out



  • My upgrade failed aswell. Didnt want to open a new thread so i post it here.

    Also 2.3.1 to 2.3.2 with NanoBSD on an Alix board. Update from console over ssh.
    Tried three times. Two times i got the following error. One time i got a timeout while fetching the packages.

    Number of packages to be removed: 1
    Number of packages to be installed: 1
    Number of packages to be upgraded: 68
    
    The process will require 2 MiB more space.
    [1/70] Upgrading gettext-runtime from 0.19.7 to 0.19.8.1...
    [1/70] Extracting gettext-runtime-0.19.8.1: .......... done
    [2/70] Upgrading python27 from 2.7.11_2 to 2.7.12...
    [2/70] Extracting python27-2.7.12: .......... done
    Child process pid=7422 terminated abnormally: Killed
    >>> Locking package pfSense-kernel-pfSense_wrap... done.
    pkg: open(/bin/sh): No such file or directory
    pkg: open(/bin/sh): No such file or directory
    pkg: Unable to determine ABI
    pkg: Cannot parse configuration file!
    pkg: open(/bin/sh): No such file or directory
    pkg: open(/bin/sh): No such file or directory
    pkg: Unable to determine ABI
    pkg: Cannot parse configuration file!
    
    


  • timeout maybe servers are overload…



  • I also had the upgrade fail, apparently on the last package. Afterward the Package Manager could not display the installed or available packages. And the main page version check would fail. Manual attempts to upgrade through the web GUI would also fail.

    I recovered using the serial console upgrade method, as others have suggested (thanks!)



  • wtffffffff…… fit it, fix it nowwwww. 🙂




  • My unit tells me that a upgrade is available and when i start the process i get this

    Updating repositories metadata…
    Updating pfSense-core repository catalogue…
    pkg: https://pkg.pfsense.org/pfSense_v2_3_1_amd64-core/meta.txz: No address record
    repository pfSense-core has no meta file, using default settings
    pkg: https://pkg.pfsense.org/pfSense_v2_3_1_amd64-core/packagesite.txz: No address record
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue…
    pkg: https://pkg.pfsense.org/pfSense_v2_3_1_amd64-pfSense_v2_3_1/meta.txz: No address record
    repository pfSense has no meta file, using default settings
    pkg: https://pkg.pfsense.org/pfSense_v2_3_1_amd64-pfSense_v2_3_1/packagesite.txz: No address record
    Unable to update repository pfSense
    Failed

    running 2.3.1_1 trying to go to 2.3.2



  • @1smallsausage:

    My unit tells me that a upgrade is available and when i start the process i get this

    Updating repositories metadata…
    Updating pfSense-core repository catalogue…
    pkg: https://pkg.pfsense.org/pfSense_v2_3_1_amd64-core/meta.txz: No address record

    Bug that’s fixed in 2.3.2, but you’ll need to bind your DNS Resolver or Forwarder to localhost first to get to 2.3.2. Do that, and upgrade again and it’ll be fine.



  • Iam still not be able to update my box.

    The first thing i figured out after doing ‘pkg clean’ is that it was mounted read-only even tho it says ‘NanoBSD is now always read-write to avoid read-write to read-only mount problems.’ in the webinterface.

    So i executed ‘/etc/rc.conf_mount_rw’. Did ‘pkg clean’ again. That went ok this time.
    Then i did ‘pfSense-upgrade -d’ and got this again:

    Number of packages to be removed: 1
    Number of packages to be installed: 1
    Number of packages to be upgraded: 69
    
    The process will require 2 MiB more space.
    [1/71] Upgrading gettext-runtime from 0.19.7 to 0.19.8.1...
    [1/71] Extracting gettext-runtime-0.19.8.1: .......... done
    [2/71] Upgrading python27 from 2.7.11_2 to 2.7.12...
    [2/71] Extracting python27-2.7.12: .......Child process pid=96087 terminated abnormally: Killed
    >>> Locking package pfSense-kernel-pfSense_wrap... 
    Locking pfSense-kernel-pfSense_wrap-2.3.2
    pkg: open(/bin/sh): No such file or directory
    pkg: open(/bin/sh): No such file or directory
    pkg: Unable to determine ABI
    pkg: Cannot parse configuration file!
    pkg: open(/bin/sh): No such file or directory
    pkg: open(/bin/sh): No such file or directory
    pkg: Unable to determine ABI
    pkg: Cannot parse configuration file!
    
    

    Any hints?

    Edit: Just checked the mount status after the failed upgrade and its mounted read-only again!

    [2.3.1-RELEASE][admin@deepthought.lan]/root: mount
    /dev/ufs/pfsense1 on / (ufs, local, noatime, read-only, synchronous)
    devfs on /dev (devfs, local)
    /dev/ufs/cf on /cf (ufs, local, noatime, synchronous)
    /dev/md0 on /tmp (ufs, local)
    /dev/md1 on /var (ufs, local)
    devfs on /var/dhcpd/dev (devfs, local)
    
    

    Could it be that something remounts it read-only while upgrading causing it to fail?!



  • Similar problem, Can Not upgrade, current version "2.3.1-RELEASE-p1 (amd64) " get this error:

    firmware installation failed!

    Updating repositories metadata…
    Updating pfSense-core repository catalogue…
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue…
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    ERROR: It was not possible to determine pkg remote version

    Locking package pfSense-kernel-pfSense… done.
    Failed
    ERROR: It was not possible to determine pfSense-repo remote version
    Failed

    Try to update Squid and Get this:

    “not_ready” and that’s all



  • Solved it now by reinstalling to full version on my Alix.

    Since nanobsd is going to be discontinued it had to do this anyway. At least i know how to install it on my cf card with virtualbox and a cf card reader now.

    Now i have to reinstall all packages and try to get freeradius to launch again. But it seems to run good so far…



  • I run into the same problem, in my case it was a bad link for the pkg cache.
    This is how I fix it:

    
    # unlink /root/var/cache/pkg
    # mkdir /root/var/cache/pkg
    
    

 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy