Package Manager or something related got damage. Need help to fix it.



  • Something got damage in my pfsense installation.

    I am suspecting a bad proxy.pac configuration, but can be other thing.

    I was working with proxy settings when suddenly nmap stop working.  Doing nmap pfsenseIP in console never ended, had to abort command by key in ctrl-z.  Run in webconfig page but returned that did not found the host and the webconfig freeze or stop responding.  Close the browser and reopen webconfig succesfully.

    Tried to fixed it by reinstalling the package.  It did but then the Package manager does not work.  It returns "unable to retrieve package information" in the Installed Application tab and the Available Packages tab.

    I run pkg remove nmap from console and it did but the Package manager still does not work in the webconfig.



  • Maybe Package Manager in webconfig is failing due to timing errors.

    I installed nmap again but using pkg install nmap. This does not install the pfsense nmap package.

    Any way I am running nmap in verbose mode:
    nmap pfsenseIP -v

    After finding the lower ports it started to dropped probes then increasing send delay.

    But why is dropping probes to the same pfsense box?  Running nmap from other box to the pfsense runs normally.

    Maybe fixing this network dropping the Packages will be retrieve succesfully in webconfig.

    So I need help to fix this network problem.  I tried rebooting and resetting states but did not fix it.

    Do you have any idea what can I do?



  • I reinstall from scratch and started to work. I think the problem is with my network card.


Log in to reply