PfSense NIC detection only on every other boot!



  • So I've been running pfSense for several weeks on a system I built from mostly new parts. The CPU was a Pentium G3220 but I recently got a deal on a Pentium G3470 for $35 so I thought why not upgrade?  I wish I hadn't because since changing the CPU, the system only sees my Intel 4-port igb NIC on EVERY OTHER BOOT.  What the heck?  On the first boot, it says "Configuration references interfaces that do not exist" but if I reboot, it is happy with the config and boots right up.  Other than the CPU, I changed nothing else in the system.  Oh, and when I go back to the old CPU, same thing. I also tried the NanoBSD version and it has the same problem on the first boot.

    Any ideas???



  • That would be attributable to either the NIC itself (maybe it's flaky), or the BIOS or motherboard. I'd try reseating the card first, maybe it got knocked a bit while replacing the CPU.



  • I feel you may be correct.  I noticed during the reboots that the connection to the cable modem is going off of gigabit when the adapter is not detected, so that may indicate that it is the NIC.  I've tried reseating it but I am going to go ahead and get another one to see if that's it.

    Thanks for the help!



  • It was indeed the NIC.  Or possibly the slot the NIC is in.  Unfortunately, the small board I have only has one x4 or larger slot, so I can't try it in another.  I got a replacement 2-port card that uses the x1 slot and that works fine boot after boot.

    Thanks again for the help.


Log in to reply