Upgrading from 2.2.6 to 2.3.2 using option 13 gives sha256 error

  • Upgrading from the web interface is no longer an option.
    Tried it once and its started, unit rebooted but still at 2.2.6 and now it can't upgrade.

    tried it from the console using option 13 and auto for the url.

    it downloads file then says sha256 checksum does not match.

    Any suggestions at this point?

    Also noticed that when I did an update from 2.3.1 it says pfsense has wrong packagesite, need to re-create database.
    That update completed. 
    ![sha256 checksum error.JPG](/public/imported_attachments/1/sha256 checksum error.JPG)
    ![sha256 checksum error.JPG_thumb](/public/imported_attachments/1/sha256 checksum error.JPG_thumb)
    ![2-3-2 upgrade error.JPG](/public/imported_attachments/1/2-3-2 upgrade error.JPG)
    ![2-3-2 upgrade error.JPG_thumb](/public/imported_attachments/1/2-3-2 upgrade error.JPG_thumb)

  • Try updating 2.2.6 again, was most likely fixed:

  • Just tried it again with the same error.

  • Rebel Alliance Developer Netgate

    Looks OK on the server

    $ fetch https://updates.pfsense.org/_updaters/amd64/latest.tgz
    latest.tgz                                    100% of  182 MB  340 kBps 09m09s
    $ fetch https://updates.pfsense.org/_updaters/amd64/latest.tgz.sha256
    latest.tgz.sha256                             100% of  150  B 2487 kBps 00m00s
    $ sha256 latest.tgz
    SHA256 (latest.tgz) = 12e1e22262f9424324e86c208d7aa741c90d1c79f6120e1b365aa942faebc247
    $ cat latest.tgz.sha256 
    SHA256 (/staging/ce/images/updates/pfSense-CE-Full-Update-2.3.1-RELEASE-amd64.tgz) = 12e1e22262f9424324e86c208d7aa741c90d1c79f6120e1b365aa942faebc247 

Log in to reply