Everlasting squid



  • May be a good thing in a restaurant but it playing havoc with my testing.
    I have squid v2.7.9 on pfsense 2.2.2. Not going to upgrade it yet as it is a production machine.

    I just want to test some routing/load balancing and want to disable squid for now. The thing is whenever I stop it in services, within 30 seconds it has started itself again

    I also stopped it from the CLI -  service squid.sh stop  which does stop it, but it starts itself back up again within a minute.

    How do I stop my self-resurrecting squid short of upgrading everything?


  • LAYER 8 Netgate

    Do your testing on the test bench?



  • Under Services/Squid Proxy Server/General uncheck the 'Enable Squid Proxy'. Hit save and then it will stop. If you just try and stop the service it will auto-restart itself..



  • @AR15USR:

    Under Services/Squid Proxy Server/General uncheck the 'Enable Squid Proxy'. Hit save and then it will stop. If you just try and stop the service it will auto-restart itself..

    Thanks - I did go in there, but can't see an option to Enable or otherwise:




  • Do you have the Service Watchdog package installed?  That might explain zombie squid rising from the dead.

    You really need to get off of that ancient squid 2.x.  It doesn't support a lot of current HTTP features and has long since been EOL.



  • @robatwork:

    @AR15USR:

    Under Services/Squid Proxy Server/General uncheck the 'Enable Squid Proxy'. Hit save and then it will stop. If you just try and stop the service it will auto-restart itself..

    Thanks - I did go in there, but can't see an option to Enable or otherwise:

    Ah, I'm on 2.3, didn't realize it wasn't like that on 2.2…



  • I've updated squid but not pfsense - I think that's the next option as it still won't stop resurrecting itself. No service watchdog installed.


Log in to reply