2.3.1 - UNABLE TO CHECK FOR UPDATES



  • Hello,

    I have a pfsense 2.3.1 firewall that now says Unable to check for updates.

    The same thing happened on our customer firewall, which always has the version 2.3.1.

    What must I check to find out the reason for this error?

    Anyone have a solution?

    Thank you and best regards





  • I have tried, as described in the link, from the shell to run the command: pfSense-ugrade -d

    below paste debugging:

    Updating repositories metadata…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.

    Unlocking package pfSense-kernel-pfSense...
    Unlocking pfSense-kernel-pfSense-2.3.1
    The following 67 package(s) will be affected (of 0 checked):

    New packages to be INSTALLED:
    dnsmasq: 2.76,1 [pfSense]

    Installed packages to be UPGRADED:
    xinetd: 2.3.15_1 -> 2.3.15_2 [pfSense]
    unbound: 1.5.8 -> 1.5.9 [pfSense]
    strongswan: 5.4.0 -> 5.5.0 [pfSense]
    sqlite3: 3.11.1 -> 3.13.0 [pfSense]
    smartmontools: 6.4_2 -> 6.5_1 [pfSense]
    rrdtool: 1.5.5_1 -> 1.6.0_1 [pfSense]
    relayd: 5.5.20140810_1 -> 5.5.20140810_2 [pfSense]
    python27: 2.7.11_2 -> 2.7.12 [pfSense]
    php56-zlib: 5.6.21 -> 5.6.23 [pfSense]
    php56-xmlwriter: 5.6.21 -> 5.6.23 [pfSense]
    php56-xmlreader: 5.6.21 -> 5.6.23 [pfSense]
    php56-xml: 5.6.21 -> 5.6.23 [pfSense]
    php56-tokenizer: 5.6.21 -> 5.6.23 [pfSense]
    php56-sysvshm: 5.6.21 -> 5.6.23 [pfSense]
    php56-sysvsem: 5.6.21 -> 5.6.23 [pfSense]
    php56-sysvmsg: 5.6.21 -> 5.6.23 [pfSense]
    php56-sqlite3: 5.6.21 -> 5.6.23 [pfSense]
    php56-sockets: 5.6.21 -> 5.6.23 [pfSense]
    php56-simplexml: 5.6.21 -> 5.6.23 [pfSense]
    php56-shmop: 5.6.21 -> 5.6.23 [pfSense]
    php56-session: 5.6.21 -> 5.6.23 [pfSense]
    php56-readline: 5.6.21 -> 5.6.23 [pfSense]
    php56-posix: 5.6.21 -> 5.6.23 [pfSense]
    php56-pdo_sqlite: 5.6.21 -> 5.6.23 [pfSense]
    php56-pdo: 5.6.21 -> 5.6.23 [pfSense]
    php56-pcntl: 5.6.21 -> 5.6.23 [pfSense]
    php56-openssl: 5.6.21 -> 5.6.23 [pfSense]
    php56-opcache: 5.6.21 -> 5.6.23_1 [pfSense]
    php56-mcrypt: 5.6.21 -> 5.6.23 [pfSense]
    php56-mbstring: 5.6.21 -> 5.6.23 [pfSense]
    php56-ldap: 5.6.21 -> 5.6.23 [pfSense]
    php56-json: 5.6.21 -> 5.6.23 [pfSense]
    php56-hash: 5.6.21 -> 5.6.23 [pfSense]
    php56-gettext: 5.6.21 -> 5.6.23 [pfSense]
    php56-filter: 5.6.21 -> 5.6.23 [pfSense]
    php56-dom: 5.6.21 -> 5.6.23 [pfSense]
    php56-curl: 5.6.21 -> 5.6.23 [pfSense]
    php56-ctype: 5.6.21 -> 5.6.23 [pfSense]
    php56-bz2: 5.6.21 -> 5.6.23 [pfSense]
    php56-bcmath: 5.6.21 -> 5.6.23 [pfSense]
    php56: 5.6.21 -> 5.6.23 [pfSense]
    php-xdebug: 2.2.5 -> 2.4.0 [pfSense]
    pfSense-rc: 2.3.1 -> 2.3.2 [pfSense-core]
    pfSense-kernel-pfSense: 2.3.1 -> 2.3.2 [pfSense-core]
    pfSense-default-config: 2.3.1 -> 2.3.2 [pfSense-core]
    pfSense-base: 2.3.1 -> 2.3.2 [pfSense-core]
    pfSense-Status_Monitoring: 1.3_1 -> 1.4.4_2 [pfSense]
    pfSense: 2.3.1 -> 2.3.2 [pfSense]
    perl5: 5.20.3_12 -> 5.20.3_13 [pfSense]
    pecl-rrd: 1.1.3_2 -> 1.1.3_3 [pfSense]
    pecl-radius: 1.2.7 -> 1.3.0 [pfSense]
    pcre: 8.38_1 -> 8.39 [pfSense]
    ntp: 4.2.8p7 -> 4.2.8p8 [pfSense]
    nginx: 1.8.1,2 -> 1.10.1,2 [pfSense]
    libssh2: 1.6.0_1,2 -> 1.7.0,2 [pfSense]
    libedit: 3.1.20150325_2 -> 3.1.20150325_2,1 [pfSense]
    isc-dhcp43-server: 4.3.3P1_1 -> 4.3.4 [pfSense]
    isc-dhcp43-relay: 4.3.3P1_1 -> 4.3.4_1 [pfSense]
    isc-dhcp43-client: 4.3.3P1_1 -> 4.3.4 [pfSense]
    ipmitool: 1.8.15_1 -> 1.8.17_1 [pfSense]
    gettext-runtime: 0.19.7 -> 0.19.8.1 [pfSense]
    filterlog: 0.1_2 -> 0.1_4 [pfSense]
    expat: 2.1.0_3 -> 2.1.1_2 [pfSense]
    curl: 7.48.0_1 -> 7.49.1 [pfSense]
    ca_root_nss: 3.22.2 -> 3.25 [pfSense]
    bind-tools: 9.10.3P4 -> 9.10.4P2 [pfSense]

    Number of packages to be installed: 1
    Number of packages to be upgraded: 66

    The process will require 2 MiB more space.
    78 MiB to be downloaded.

    **** WARNING ****
    Reboot will be required!!
    Proceed with upgrade? (y/N) read: read error: Socket is not connected
    Aborting…

    Locking package pfSense-kernel-pfSense...
    Locking pfSense-kernel-pfSense-2.3.1



  • Solved,

    I have connected to the firewall via SSH with putty and I've run the following commands:

    pkg update -f
    pkg upgrade -f

    SOLVED !

    Greetings to everyone



  • This thread fixed my update issue. Upgraded from 2.2.6 I think  to 2.3.1 and couldnt update, check packages nothing. Following this thread fixed it for me and now im updated and everything is working.


Log in to reply