SG-2220 Upgrade Failure / Recovery Help



  • Good afternoon.
      A couple of days ago I attempted to upgrade to 2.3.2 as a result the router never booted after the completion. I attempted to factory reset the device with no success. When booting the router I get the following output ( attached as a file to this post )

    Would someone be kind enough to point me to the NetGate PFSense software ( as opposed to CE ) so that I might recover this device or kindly provide some pointers? I'd very much appreciate it. Thank you.
    pfsense.txt



  • Sorry. I cut off my log file a little too early at the end. The remainder shows as follows

    panic: mountroot: unable to (re-)mount root.
    cpuid = 1
    KDB: enter: panic
    [ thread pid 1 tid 100002 ]
    Stopped at      kdb_enter+0x3e: movq    $0,kdb_why



  • Installed the ADI inage and life is happy again. Hoping this was a one off


  • Rebel Alliance Developer Netgate

    Sounds like it had an issue with the filesystem. It's unlikely that was related to the upgrade, but it's possible the extra activity from the upgrade brought it to the surface.



  • Mine died after the update as well and with a console cable it shows:
    #######Start#########
    Booting from Hard Disk…

    F1  pfSense
    F5  Drive 1

    F6 PXE
    Boot:  F1

    __ ____                         
      _ __  / / |  ___ _ __  ___  ___   
      | '
    | |
    _
    \ / _ \ '_ / |/ _ \   
      | |) |  |
    ) |  / | | _/   
      | .
    /|| |___/ _
    || ||/_|   
      |
    |

    +============Welcome to pfSense===========+                             
    |                                        |                ______       
    |  1. Boot Multi User [Enter]            |                /      \     
    |  2. Boot ~~ingle User                  |          /    f  \     
    |  3. [Esc]ape to loader prompt          |        /    \        /     
    |  4. Reboot                              |        /  p  _
    /  Sense
    |                                        |        \      /      \     
    |  Options:                              |        _____/        \     
    |  5. [K]ernel: kernel (1 of 2)          |              \        /     
    |  6. Configure Boot [O]ptions…        |                ______/     
    |                                        |                             
    |                                        |                             
    |                                        |                               
    +=========================================+

    /boot/kernel/kernel text=0x1292d98 data=0x8a1bb0+0x23ec10 syms=[0x8+0x177720+0x8+0x173eef]
    Booting…
    KDB: debugger backends: ddb
    KDB: current backend: ddb
    Copyright (c) 1992-2016 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 10.3-RELEASE-p5 #0 7307492(RELENG_2_3_2): Tue Jul 19 13:29:18 CDT 2016
        root@factory23-amd64-builder:/builder/factory-232/tmp/obj/builder/factory-232/tmp/FreeBSD-src/sys/pfSense amd64
    FreeBSD clang version 3.4.1 (tags/RELEASE_34/dot1-final 208032) 20140512
    CPU: Intel(R) Atom(TM) CPU  C2358  @ 1.74GHz (1750.04-MHz K8-class CPU)
      Origin="GenuineIntel"  Id=0x406d8  Family=0x6  Model=0x4d  Stepping=8
      Features=0xbfebfbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>Features2=0x43d8e3bf <sse3,pclmulqdq,dtes64,mon,ds_cpl,vmx,est,tm2,ssse3,cx16,xtpr,pdcm,sse4.1,sse4.2,movbe,popcnt,tscdlt,aesni,rdrand>AMD Features=0x28100800 <syscall,nx,rdtscp,lm>AMD Features2=0x101 <lahf,prefetch>Structured Extended Features=0x2282 <tscadj,smep,erms,nfpusg>VT-x: PAT,HLT,MTF,PAUSE,EPT,UG,VPID
      TSC: P-state invariant, performance statistics
    real memory  = 6442450944 (6144 MB)
    avail memory = 4067180544 (3878 MB)
    Event timer "LAPIC" quality 600
    ACPI APIC Table: <core  coreboot="">FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
    FreeBSD/SMP: 1 package(s) x 2 core(s)
    cpu0 (BSP): APIC ID:  0
    cpu1 (AP): APIC ID:  2
    random: <software, yarrow="">initialized
    ioapic0 <version 2.0="">irqs 0-23 on motherboard
    wlan: mac acl policy registered
    ipw_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_bss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_bss_fw, 0xffffffff806208f0, 0) error 1
    ipw_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_ibss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_ibss_fw, 0xffffffff806209a0, 0) error 1
    ipw_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_monitor: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_monitor_fw, 0xffffffff80620a50, 0) error 1
    iwi_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi/.
    iwi_bss: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (iwi_bss_fw, 0xffffffff80647bf0, 0) error 1
    iwi_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi/.
    iwi_ibss: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (iwi_ibss_fw, 0xffffffff80647ca0, 0) error 1
    iwi_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi/.
    iwi_monitor: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (iwi_monitor_fw, 0xffffffff80647d50, 0) error 1
    netmap: loaded module
    kbd0 at kbdmux0
    module_register_init: MOD_LOAD (vesa, 0xffffffff81016b90, 0) error 19
    cryptosoft0: <software crypto="">on motherboard
    padlock0: No ACE support.
    acpi0: <core coreboot="">on motherboard
    acpi0: Power Button (fixed)
    hpet0: invalid period
    device_attach: hpet0 attach returned 6
    cpu0: <acpi cpu="">on acpi0
    cpu1: <acpi cpu="">on acpi0
    hpet0: invalid period
    device_attach: hpet0 attach returned 6
    atrtc0: <at realtime="" clock="">port 0x70-0x77 on acpi0
    Event timer "RTC" frequency 32768 Hz quality 0
    attimer0: <at timer="">port 0x40-0x43,0x50-0x53 irq 0 on acpi0
    Timecounter "i8254" frequency 1193182 Hz quality 0
    Event timer "i8254" frequency 1193182 Hz quality 100
    Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
    pcib0: <acpi host-pci="" bridge="">port 0xcf8-0xcff on acpi0
    pci0: <acpi pci="" bus="">on pcib0
    pcib1: <acpi pci-pci="" bridge="">mem 0xdfec0000-0xdfedffff irq 16 at device 1.0 on pci0
    pci1: <acpi pci="" bus="">on pcib1
    pcib2: <acpi pci-pci="" bridge="">mem 0xdfee0000-0xdfefffff irq 19 at device 2.0 on pci0
    pci2: <acpi pci="" bus="">on pcib2
    pcib3: <acpi pci-pci="" bridge="">mem 0xdff00000-0xdff1ffff irq 20 at device 3.0 on pci0
    pci3: <acpi pci="" bus="">on pcib3
    pcib4: <acpi pci-pci="" bridge="">mem 0xdff20000-0xdff3ffff irq 23 at device 4.0 on pci0
    pci4: <acpi pci="" bus="">on pcib4
    pci0: <processor>at device 11.0 (no driver attached)
    pci0: <base peripheral,="" iommu=""> at device 15.0 (no driver attached)
    igb0: <intel(r) 1000="" pro="" network="" connection,="" version="" -="" 2.5.3-k="">port 0x1000-0x101f mem 0xdff60000-0xdff7ffff,0xdffe4000-0xdffe7fff irq 18 at device 20.0 on pci0
    igb0: Using MSIX interrupts with 3 vectors
    igb0: Ethernet address: 00:08:a2:09:2d:56
    igb0: Bound queue 0 to cpu 0
    igb0: Bound queue 1 to cpu 1
    igb0: netmap queues/slots: TX 2/1024, RX 2/1024
    igb1: <intel(r) 1000="" pro="" network="" connection,="" version="" -="" 2.5.3-k="">port 0x1020-0x103f mem 0xdff80000-0xdff9ffff,0xdffe8000-0xdffebfff irq 19 at device 20.1 on pci0
    igb1: Using MSIX interrupts with 3 vectors
    igb1: Ethernet address: 00:08:a2:09:2d:57
    igb1: Bound queue 0 to cpu 0
    igb1: Bound queue 1 to cpu 1
    igb1: netmap queues/slots: TX 2/1024, RX 2/1024
    igb2: <intel(r) 1000="" pro="" network="" connection,="" version="" -="" 2.5.3-k="">port 0x1040-0x105f mem 0xdffa0000-0xdffbffff,0xdffec000-0xdffeffff irq 20 at device 20.2 on pci0
    igb2: Using MSIX interrupts with 3 vectors
    igb2: Ethernet address: 00:08:a2:09:2d:58
    igb2: Bound queue 0 to cpu 0
    igb2: Bound queue 1 to cpu 1
    igb2: netmap queues/slots: TX 2/1024, RX 2/1024
    igb3: <intel(r) 1000="" pro="" network="" connection,="" version="" -="" 2.5.3-k="">port 0x1060-0x107f mem 0xdffc0000-0xdffdffff,0xdfff0000-0xdfff3fff irq 21 at device 20.3 on pci0
    igb3: Using MSIX interrupts with 3 vectors
    igb3: Ethernet address: 00:08:a2:09:2d:59
    igb3: Bound queue 0 to cpu 0
    igb3: Bound queue 1 to cpu 1
    igb3: netmap queues/slots: TX 2/1024, RX 2/1024
    ehci0: <intel avoton="" usb="" 2.0="" controller="">mem 0xdfff5400-0xdfff57ff irq 22 at device 22.0 on pci0
    usbus0: EHCI version 1.0
    usbus0 on ehci0
    ahci0: <intel avoton="" ahci="" sata="" controller="">port 0x10c0-0x10c7,0x10e0-0x10e3,0x10c8-0x10cf,0x10e4-0x10e7,0x1080-0x109f mem 0xdfff4000-0xdfff47ff irq 23 at device 23.0 on pci0
    ahci0: AHCI v1.30 with 2 3Gbps ports, Port Multiplier not supported
    ahcich0: <ahci channel="">at channel 0 on ahci0
    ahci1: <intel avoton="" ahci="" sata="" controller="">port 0x10d0-0x10d7,0x10e8-0x10eb,0x10d8-0x10df,0x10ec-0x10ef,0x10a0-0x10bf mem 0xdfff4800-0xdfff4fff irq 16 at device 24.0 on pci0
    ahci1: AHCI v1.30 with 2 6Gbps ports, Port Multiplier not supported
    isab0: <pci-isa bridge="">at device 31.0 on pci0
    isa0: <isa bus="">on isab0
    orm0: <isa option="" rom="">at iomem 0xc0000-0xc0fff on isa0
    ppc0: cannot reserve I/O port range
    uart0: <16550 or compatible> at port 0x3f8-0x3ff irq 4 on isa0
    uart1: <16550 or compatible> at port 0x2f8-0x2ff irq 3 flags 0x10 on isa0
    uart1: console (115200,n,8,1)
    est0: <enhanced speedstep="" frequency="" control="">on cpu0
    est1: <enhanced speedstep="" frequency="" control="">on cpu1
    Timecounters tick every 1.000 msec
    random: unblocking device.
    usbus0: 480Mbps High Speed USB v2.0
    ugen0.1: <intel>at usbus0
    uhub0: <intel 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usbus0
    uhub0: 8 ports with 8 removable, self powered
    ugen0.2: <vendor 0x8087="">at usbus0
    uhub1: <vendor 2="" 9="" 0x8087="" product="" 0x07db,="" class="" 0,="" rev="" 2.00="" 0.02,="" addr="">on usbus0
    uhub1: 4 ports with 4 removable, self powered
    ugen0.3: <generic>at usbus0
    umass0: <generic 0="" 3="" ultra="" fast="" media,="" class="" 0,="" rev="" 2.00="" 1.98,="" addr="">on usbus0
    ada0 at ahcich0 bus 0 scbus0 target 0 lun 0
    ada0: da0 at umass-sim0 bus 0 scbus1 target 0 lun 0
    da0: <generic ultra="" hs-combo="" 1.98="">Removable Direct Access SCSI device
    da0: Serial Number 000000225001
    da0: 40.000MB/s transfers
    da0: 3648MB (7471104 512 byte sectors)
    da0: quirks=0x2 <no_6_byte><intel ssdmceac030b3="" llli="">ACS-2 ATA SATA 3.x device
    ada0: Serial Number CVLI446200AH030H
    ada0: 300.000MB/s transfers (SATA 2.x, UDMA6, PIO 8192bytes)
    ada0: Command Queueing enabled
    ada0: 28626MB (58626288 512 byte sectors)
    ada0: Previously was known as ad4
    SMP: AP CPU #1 Launched!
    Timecounter "TSC" frequency 1750043463 Hz quality 1000
    Trying to mount root from ufs:/dev/ufsid/5547a0ac3666f3d5 [rw]…
    WARNING: / was not properly dismounted
    ##########END###############
    At which point it locks up...</intel></no_6_byte></generic></generic></generic></vendor></vendor></intel></intel></enhanced></enhanced></isa></isa></pci-isa></intel></ahci></intel></intel></intel(r)></intel(r)></intel(r)></intel(r)></processor></acpi></acpi></acpi></acpi></acpi></acpi></acpi></acpi></acpi></acpi></at></at></acpi></acpi></core></software></version></software,></core ></tscadj,smep,erms,nfpusg></lahf,prefetch></syscall,nx,rdtscp,lm></sse3,pclmulqdq,dtes64,mon,ds_cpl,vmx,est,tm2,ssse3,cx16,xtpr,pdcm,sse4.1,sse4.2,movbe,popcnt,tscdlt,aesni,rdrand></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>~~


  • Rebel Alliance Developer Netgate

    It probably isn't locked up there. At that point it switches over to displaying the pfSense startup console messages, but for some reason it cannot. It's possible there is something amiss with the console or terminal settings on the box at that point. By far the fastest and easiest way to recover is to reinstall and restore your configuration. If you don't have a backup, use the "rescue config.xml" option in the installer – multiple times if it fails the first try -- and you'll be back up in a few minutes.

    If you haven't yet registered your firewall, do so and/or login to https://portal.pfsense.org/ and you should have a link to the factory firmware for that unit. If your support expired, just grab the ADI install image from pfsense.org for 2.3.2 and do the same.


Log in to reply