2.3.2 Upgrade Issue (NanoBSD)



  • I tried to update from 2.3.1 to 2.3.2 on NanoBSD system today, using pfSense-upgrade -d option. Below are the results, and after the restart the system was still at 2.3.1 but booting from the other slice (started on slice 1 and ended up after the reboot on slice 2).

    [2.3.1-RELEASE][admin@firewall2.xxxx.lan]/root: pfSense-upgrade -d

    Updating repositories metadata…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    **** WARNING ****
    Duplicate slice required!!

    Before starting the upgrade process, the currently mounted nanobsd partition
    needs to be cloned to the secondary partition, where the update will happen

    After installation a reboot will be required to switch partition.

    Proceed with upgrade? (y/N) N
    Aborting...
    [2.3.1-RELEASE][admin@firewall2.xxxx.lan]/root: pkg install pfSense-pkg-System_Patches
    Updating pfSense-core repository catalogue…
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    The following 1 package(s) will be affected (of 0 checked):

    New packages to be INSTALLED:
            pfSense-pkg-System_Patches: 1.1.4_1 [pfSense]

    Number of packages to be installed: 1

    8 KiB to be downloaded.

    Proceed with this action? [y/N]: y
    Fetching pfSense-pkg-System_Patches-1.1.4_1.txz: 100%    8 KiB  8.6kB/s    00:01
    Checking integrity… done (0 conflicting)
    [1/1] Installing pfSense-pkg-System_Patches-1.1.4_1…
    [1/1] Extracting pfSense-pkg-System_Patches-1.1.4_1: 100%
    Saving updated package information…
    done.
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    Custom commands...
    Executing custom_php_install_command()...done.
    Menu items... done.
    Writing configuration... done.
    [2.3.1-RELEASE][admin@firewall2.xxxx.lan]/root: pfSense-upgrade -d

    Updating repositories metadata…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    **** WARNING ****
    Duplicate slice required!!

    Before starting the upgrade process, the currently mounted nanobsd partition
    needs to be cloned to the secondary partition, where the update will happen

    After installation a reboot will be required to switch partition.

    Proceed with upgrade? (y/N) y

    Cleaning secondary partition...
    1+0 records in
    1+0 records out
    1048576 bytes transferred in 0.079989 secs (13109010 bytes/sec)

    Duplicating current slice...
    30034+1 records in
    30034+1 records out
    1968349696 bytes transferred in 222.997821 secs (8826766 bytes/sec)

    Restoring slice label...
    Testing duplicated partition integrity...
    ** /dev/ufs/pfsense1
    ** Last Mounted on /
    ** Phase 1 - Check Blocks and Sizes
    ** Phase 2 - Check Pathnames
    ** Phase 3 - Check Connectivity
    ** Phase 4 - Check Reference Counts
    ** Phase 5 - Check Cyl groups
    16341 files, 1024377 used, 2755651 free (2403 frags, 344156 blocks, 0.1% fragmentation)

    ***** FILE SYSTEM IS CLEAN *****

    Mounting second partition to run upgrade...
    Unlocking package pfSense-kernel-pfSense_wrap_vga...
    Unlocking pfSense-kernel-pfSense_wrap_vga-2.3.1

    Downloading upgrade packages...
    Updating pfSense-core repository catalogue...
    Unable to update repository pfSense-core
    Updating pfSense repository catalogue...
    Unable to update repository pfSense
    All repositories are up-to-date.
    pkg: Repository pfSense-core cannot be opened. 'pkg update' required
    pkg: Repository pfSense cannot be opened. 'pkg update' required
    Checking for upgrades (0 candidates): . done
    Processing candidates (0 candidates): . done
    Checking integrity... done (0 conflicting)
    Your packages are up to date.
    pkg: Repository pfSense-core cannot be opened. 'pkg update' required
    pkg: Repository pfSense cannot be opened. 'pkg update' required
    pkg: No packages available to upgrade matching 'pfSense-kernel-pfSense_wrap_vga' have been found in the repositories
    pkg: Repository pfSense-core cannot be opened. 'pkg update' required
    pkg: Repository pfSense cannot be opened. 'pkg update' required
    pkg: Repository pfSense-core cannot be opened. 'pkg update' required
    pkg: Repository pfSense cannot be opened. 'pkg update' required

    Setting secondary partition as active...
    active set on da0s2
    Upgrade is complete.  Rebooting in 10 seconds.

    Broadcast Message from admin@firewall2.xxxx.lan
            (/dev/pts/0) at 17:53 EDT...

    Upgrade is complete.  Rebooting in 10 seconds.

    Locking package pfSense-kernel-pfSense_wrap_vga...
    Locking pfSense-kernel-pfSense_wrap_vga-2.3.1
    [2.3.1-RELEASE][admin@firewall2.xxxx.lan]/root: Shutdown NOW!
    shutdown: [pid 91547]

    *** FINAL System shutdown message from admin@firewall2.xxxx.lan ***

    System going down IMMEDIATELY

    System shutdown time has arrived


Log in to reply