No internet on IPSec client while using OpenVPN client on same pfSense server



  • Dear forum members,

    I have a problem with my pfSense router and the IPsec VPN server on it.

    The IPsec VPN connection established without any problems and I can ping my LAN devices through the IPsec VPN Tunnel.
    The problem is that I don’t have internet access on my clients that connects with my IPsec VPN server.
    Everything worked without any problems before. The problems started when I add a OpenVPN client on my pfSense router.

    The OpenVPN client connects to a VPN server to be more anonymous when downloading content.
    When I disable the interface of my OpenVPN client my IPsec VPN server works like a champ (ping LAN devices and have internet access on my clients)!

    I think there is a config problem or a NAT problem.

    • When I enable the OpenVPN client I can download anonymous through the OpenVPN tunnel, but I don’t have internet access on my IPsec VPN clients
    • When I disable the OpenVPN client I can’t download anonymous because I use my public IP and not the IP of the VPN server where I’m connecting to.
          By IPsec VPN server works like a champ. I can ping LAN devices and have internet access when I’m connected.

    I have tried to force the traffic from my IPsec trough my default gateway. If I set the settings like below I have internet access on my IPsec clients, but I can’t ping my LAN devices.

    Drives me a little crazy right now.. ??? Hope someone can push me in the right direction.

    Here are my settings:




Log in to reply