UDP packets not getting through to PBX VOIP system.



  • Hi All,

    Got a new VOIP system installed (UNIFY Openscape). I have a PBX server here with IP phones in the office. Then I have external phones that will go at remote sites.

    When testing the phones register and calls connect but I have no audio in either direction between me and a remote site.

    setup as follows.
    PBX 172.20.100.45 on LAN1 using PFsense as a gateway (172.20.100.160).
    I have forwarded all the ports I was instructed for SIP and remote access and they all work perfectly.
    i assume it's the UDP packets that are being transformed in some way so audio is blocked.

    I set NAT rules as follows. all .45 are for the PBX)

    Rules
    Interface Protocol Source Address Source Ports Dest. Address Dest. Ports NAT IP NAT Ports Description Actions
    WAN TCP * * * 554 192.168.2.25 554 alienDRV 554
    WAN TCP * * * 8000 192.168.2.25 8000 AlienDRV
    WAN TCP * * * 10099 172.20.100.45 443 (HTTPS) NIX remote (https)
    WAN TCP * * * 10098 172.20.100.45 7000 (MMS/UDP) NIX remote (7000)
    WAN TCP * * * 4070 172.20.100.45 4060 NIX remote (7000)
    WAN TCP * * * 8802 172.20.100.45 8802 NIX remote (7000)
    WAN UDP * * * 30274 - 30600 172.20.100.45 30274 - 30600 NIX remote (7000) (retail phones)
    WAN TCP * * * RiekerWebServerPorts RiekerWebServer RiekerWebServerPorts rieker internal webserver

    I have also tried making SURE any SIP_AGL flags are disabled in any routers.

    I have tried combinations of advice on
    https://doc.pfsense.org/index.php/VoIP_Configuration

    and the issues seem the same. the only thing I haven't tried is Siproxd but seems to be for if my PBX was external?

    I have tried disabling scrub, setting firewall to conservative etc. so I am thinking I am missing something vital somewhere or I need to attack this a different way.

    I am still getting my head around PFsense so apologies if I have missed something obvious or forgotten to include vital information.



  • Assuming all port forward are correct:

    Is there any setting for NAT in your PBX?

    You have to reply to the phones with your public ip and not your private one in the sip headers

    Try setting the outbound NAT for .45 udp traffic to wan address with static port



  • My external phones register but the moment I make a call all goes wrong. I am pretty sure all my port forwards are correct as I can access the PBX's admin page externally etc.

    I have tried setting static ports for my outgoing nat on the UDP ports. so perhaps I need to set out going nat on all the ports from my PBX's internal ip address.

    the PBX supplier is telling me that the PBX is reporting that my nat is symmetric no matter what changes I seem to make. I am no expert in this and it's grinding on me.

    I will try and get some screen shots of all my settings.



  • got some screen shots of my setup now.
    from what I can tell this should be working.

    PBX alias is my PBX on LAN (172.20.100.45) and the PBX ports are the UDP ports 30274:30600.

    I can only assume that some form of port re-write is taking place somewhere. or I have rules in the wrong order or something. I have tried my best to solve the issue myself but I am really stuck now.
    I am newish to PF sense and new to routing in general so I would like to clue myself up as much as possible as to why this doesn't work like I expect.



    ![out going nat.PNG](/public/imported_attachments/1/out going nat.PNG)
    ![out going nat.PNG_thumb](/public/imported_attachments/1/out going nat.PNG_thumb)
    ![out going setup.PNG](/public/imported_attachments/1/out going setup.PNG)
    ![out going setup.PNG_thumb](/public/imported_attachments/1/out going setup.PNG_thumb)
    ![Port Forward.PNG](/public/imported_attachments/1/Port Forward.PNG)
    ![Port Forward.PNG_thumb](/public/imported_attachments/1/Port Forward.PNG_thumb)



  • It seems I solved my issue by simply changing the order of certain NAT rules.



  • What rules did you change?  Do you recall?

    I'm having similar sounding problems, but everything looks right to me.

    https://forum.pfsense.org/index.php?topic=121139.0