Install applications on PFsense



  • My local internt provider has increase the internet security by introduction an application that must run at startup on every computer. the provider give me an username and a password which i use in application to loggin to server. the problem is that no router on the market will work anymore since the provider program verifi the TTL, and i hope go get PFsense to work by installing the program on it. For windows the problem is simple, but for Linux/Unix i must follow this guide:

    " For instalation of application on Unix\Linux O.S. is necesary that you have previous installed libmcrypt, PHP-CLI, Zend and GNU Wget packets.
    1. Download libmcrypt 2.5.7 (tar.gz) [4,187Kb] http://acces.czone.ro/czone/download/libmcrypt/libmcrypt-2.5.7.tar.gz

    
    $ tar -xvzf libmcrypt-2.5.7.tar.gz 
    $ cd libmcrypt-2.5.7/ 
    $ ./configure 
    $ make 
    $ make install
    

    2. Download PHP 5.1.2 (tar.gz) [7,875Kb] http://acces.czone.ro/czone/download/php/php-5.1.2.tar.gz

    
    $ tar -xvzf php-5.1.2.tar.gz 
    $ cd php-5.1.2/ 
    $ ./configure --disable-libxml --disable-dom --disable-simplexml --disable-xml --disable-xmlreader --disable-xmlwriter --without-pear --with-openssl --with-mcrypt --enable-force-cgi-redirect --with-config-file-path=/etc --with-cli --bindir=/usr/bin 
    $ make 
    $ make install
    

    3. Download correct Zend version for your O.S. type

    
    $ tar -xvzf ZendOptimizer-version.tar.gz 
    $ cd ZendOptimizer-version/ 
    $ ./install
    

    During instalation you will be asked for location of php.ini, and whrite /etc

    4.Download Wget 1.10.2 (tar.gz) [1,221Kb]  http://acces.czone.ro/czone/download/wget/wget-1.10.2.tar.gz

    
    $ tar -xvzf wget-1.10.2.tar.gz 
    $ cd wget-1.10.2/ 
    $ ./configure 
    $ make 
    $ make install
    

    5. Download C-zone application from here: http://acces.czone.ro/czone/download/czone.sh

    5.1 Make the script executable ( ex.: chmod +x czone.sh ).

    5.2 Give the command:

    
    $ php czone.sh username password interface 
    

    "

    I really appreciate any help.
    –-------------
    Regards,
    Marius



  • I couldn't access your links.
    PHP 5 is only available in pfSense 1.3
    fetch instead of wget if possible.
    I would make contact to the ISP and try to convince them to make a package for pfSense.



  • Thanx Perry for your quick reply. I contact my ISP , but they don't help me with any information. I have an Iphone and a X-Box 360 and i cannot access the internet with them because is no login application build for Iphone or X-box. I upload files to another server, except are zend that i don't know what version to download. http://mariusmotea.evonet.ro/For PFsense/ .
    –----------------
    Regards,
    Marius



  • its easy change ISP


Log in to reply