Help with ALIX - reboot needed ~10min!!



  • Hi. I have been working on my home networking setup and recently installed all new cat6 in my house and created a "server closet" in my basement to house all of my network and computer equipment. I was using a linksys router for a while and the performance sucked. Naturally I grabbed an old computer and started testing out some firewall software. I tried IP cop which worked great. Then I decided that an embeded system with freeBSD would be the way to go.

    I ordered a 2c3 ALIX board and loaded up m0n0wall. Everything worked great… for about 10 minutes. After that I could not access the internet. I needed to reboot to get another 10 minutes out of it. Then I tried PFsense. Much easier install and I like the features... but ~10 minutes later... no internet. I can ping the firewall but I cannot ping outside to google etc. I can access the firewall via serial interface, I can ping google.com from there but from any desktop I cant even access the firewalls web page to set it up. I can still issue serial commands and everything look like it is working but it just isnt doing its job.

    I have tried two different flash cards, reflashing the software... etc etc... I am wondering what I can try next because it doesnt seem that I am doing anything wrong here yet it is not working.... I have tried to post this question on the m0n0wall forums when I was trying to get m0n0wall to run but I have got no reply in two days... I am hoping someone can help.

    I have road runner cable internet btw if that makes a difference....



  • Do you see anything in the logs when that happens?
    It "could" be the ALIX itself (a friend once recieved a buggy WRAP and had to send it in again).

    Have you tried other software on the alix?



  • Run the following command from the console to see if you can detect any messages regarding the problem.

    clog /var/log/system.log|more
    and
    dmesg|more

    Could also be that you have a switch issue of sorts. Something you can try is replacing the power supply by something beefier. A 12V 1A or 1.2A would be great. Don't use power supplies higher then 18 Volts!



  • I have left it on and left the house since my last post. When I came home it didnt work at all. Then like 15 minutes later it started working for no reason what so ever. I did not restart it and all of a sudden it is working again. I dont understand. I have a 15v 1.2A powersupply that is working fine… The lights never show any indication of a problem and the console always works... it is just the web interface and internet that doesnt work. I have tried m0nowall and pfsense.... any more ideas besides a bad board?



  • Patch cable??



  • @chpalmer:

    Patch cable??

    Same setup works fine with ipcop. I have an old pc setup with ipcop. I just swapped it out for the ALIX board. Its working right now but hasnt for the past 30 min… it seems to work in spurts.... idk.... I would really like this to work so that I can get a few clients of mine to use them to vpn between offices.... :-/



  • Which version of the firmware are you using?



  • @chpalmer:

    Which version of the firmware are you using?

    1.2 embedded



  • Just checking, but you are running the 0.99 bios on that, right?



  • @dotdash:

    Just checking, but you are running the 0.99 bios on that, right?

    Yes. And I just tried 1.2.1 which seems to work slightly better but still lose all connectivity except the serial port every 10 min



  • some new developements. When I reset my switches or sometimes disable and renable wifi or LAN conn I can connect to the Internet fine. The LAN still works fine the whole time and it does the same thing with static and dynamic ip on all the pcs. I still haven't figured this out. I might have to go back to ipcop.



  • I have gone back to using my linksys router while I sort out this ALIX problems. I am currently building a server closet which should be done in a day or two so we will see how things shape up when everything is installed in its final place.

    I am hoping someone can provide a suggestion as to anything I can try or something I might be doing wrong….



  • Hi,

    I suppose i shouldn't complain as my alix decides to reboot itself ever few hours instead of me having to go and physically reboot it!

    But I am sick of it now.  With no warning I get a fatal trap 12 page fault panic and it reboots, I've tried re-installing on different CF cards, resizing the image so the diskusage isn't hovering at 94%, updated bios to 0.99, put the box on a ups with surge protection etc… I'm lost!

    Is it time to send it back and get a new one sent out and just deal with the downtime?



  • Are this page faults in 1.2 or 1.2.1?
    Can you be more verbose on your setups?



  • yes sorry

    Latest (stable 1.2) embedded release running on a 1Gb CF card (not re-sized so really 128) with the 0.99 tiny bios.

    I have 2 wan connections load balanced using the guide from the forum with a handfull of nat rules pointing to a couple of servers on the lan.

    here is an example of something I captured thru the serial:

    enter an option: kernel trap 12 with interrupts disabled

    Fatal trap 12: page fault while in kernel mode
    fault virtual address  = 0x4f0c92cc
    fault code              = supervisor read, page not present
    instruction pointer    = 0x20:0xc0631273
    stack pointer          = 0x28:0xcbff1cec
    frame pointer          = 0x28:0xcbff1d0c
    code segment            = base 0x0, limit 0xfffff, type 0x1b
                            = DPL 0, pres 1, def32 1, gran 1
    processor eflags        = resume, IOPL = 0
    current process        = 35 (schedcpu)
    trap number            = 12
    panic: page fault
    Uptime: 30m14s
    Cannot dump. No dump device defined.
    Automatic reboot in 15 seconds - press a key on the console to abort

    This happens every so often but at least once a day.


Locked