Huawei Modem E3276 on pfSense 2.3.2



  • Dear pfSensers,

    I have this Huawei U3276 modem installed in pfSense and it is recognized as ue0.
    I set this device as WAN 2 (opt5), set IPv4 Configuration Type as DHCP.
    From menu Status->Interfaces it looks like the picture (jpg) attached.
    It always gets IP addr 0.0.0.0 and subnet mask 255.0.0.0 .
    I am confused after hours searching for the solution.
    I have done usb_modeswitch but it ended with no luck.
    Help is all I need right now….

    Best Regards,
    Andry Bangun



  • Is this really U3276 or E3276 ?
    What is the firmware version in your modem?



  • @AndrewZ:

    Is this really U3276 or E3276 ?
    What is the firmware version in your modem?

    Dear AndrewZ,

    You are right, my bad…. it's E3276 using version 23.015.02.01.910.

    Best Regards,
    Andry Bangun



  • @andry_byb:

    using version 23.015.02.01.910.

    This seems to be Dashboard or Mobile Partner version, but the question was about the modem firmware.
    Should be starting with 21 or 22.



  • @AndrewZ:

    @andry_byb:

    using version 23.015.02.01.910.

    This seems to be Dashboard or Mobile Partner version, but the question was about the modem firmware.
    Should be starting with 21 or 22.

    Dear AndrewZ
      The firmware version is 21.491.03.01.00.

    Best Regards,
    Andry Bangun



  • Average Huawei modem with 21.X firmware could be used in either RAS (PPP) or NDIS (network card) mode.

    Please follow this thread for PPP configuration. This is a standard supported way to use such modems in pfSense. It's not the best, though.

    If you want to experiment with NDIS - you will need to find a way to send an additional command to the modem which will actually bring the connection up, it was described here.



  • @AndrewZ:

    Average Huawei modem with 21.X firmware could be used in either RAS (PPP) or NDIS (network card) mode.

    Please follow this thread for PPP configuration. This is a standard supported way to use such modems in pfSense. It's not the best, though.

    If you want to experiment with NDIS - you will need to find a way to send an additional command to the modem which will actually bring the connection up, it was described here.

    Dear AndrewZ,

    Ok, I am going to try those steps. I'll comeback soon with the result. Hopefully it will be a good result. Thank you AndrewZ.

    Best Regards,
    Andry Bangun



  • Dear All,
        After ugrading E3276 firmware, the modem successfully delivered IP address but I could not login to it's administration page in order to set parameters needed by the ISP. After several attempts with various methods, I gave up and restored the original firmware and replaced E3276 with ZTE MF90. All problem is gone now.

    Best Regards,
    Andry Bangun