2.3.1-5 -> 2.3.2 upgrade error breaks Snort



  • I upgraded last night to 2.3.2 from 2.3.1-5.  The upgrade seems to be successful, but I get a PHP warning and a link to the following report from the status screen.

    amd64
    10.3-RELEASE-p5
    FreeBSD 10.3-RELEASE-p5 #0 7307492(RELENG_2_3_2): Tue Jul 19 13:29:35 CDT 2016    root@ce23-amd64-builder:/builder/pfsense-232/tmp/obj/builder/pfsense-232/tmp/FreeBSD-src/sys/pfSense

    Crash report details:

    PHP Errors:
    [08-Aug-2016 10:16:17 Europe/London] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/suhosin.so' - /usr/local/lib/php/20131226/suhosin.so: Undefined symbol "ps_globals" in Unknown on line 0

    /usr/local/lib/php/20131226/suhosin.so exists, I have checked.  Any ideas?  This is on my backup installation (I always upgrade that first), and I would like to have this working properly before moving onto my main firewall.

    TIA



  • This is a known issue in certain corner cases. This will fix the problem:
    https://forum.pfsense.org/index.php?topic=112543.msg626438#msg626438



  • Thanks, will go look at that … very much appreciated.  I thought it would have been somewhere but my search turned up nothing ...


Log in to reply