Failed loading /usr/local/lib/php/20131226/xd: Cannot open "/usr/local/lib/php/2



  • Hello, getting the following error on the console after boot.

    Failed loading /usr/local/lib/php/20131226/xd: Cannot open "/usr/local/lib/php/20131226/xd"

    I noticed the error after upgrading from 2.2.6 to 2.3.2

    The upgrade did not go well.  I had all sorts of alerts about my Traffic Shaping rules, that never generated alerts in 2.2.6.  I deleted the traffic shaping rules that were alerting and pfsense locked up requiring a hard reboot.

    After that it went downhill quick, with watch dog errors on the WAN right after booting up that would causing the system to reboot again.  Basically I was stuck in a loop of reboots.

    I tried unplugging the WAN cable and started getting Kernel errors on boot.  I was in a rush to get everything working again so I didn't document at all.  Short of it though was I had to disable the interface I was using for WAN in the BIOS to get it to boot far enough to where I could access pfsense.  Once it was that far, pfsense asked me to pick a new WAN interface, which I did.  Next I went back to the BIOS reenabled the disabled interface and booted back into pfsense.  At this point a did a restore of a backup I took before the upgrade.  Everything came up, same alerts on the Traffic Shaping rules I had before.  This time I just deleted the shaper which seemed to work, no lockups.

    Now as I am going through and checking the logs to make sure I didn't break anything else I noticed the error I started the thread with.


  • Rebel Alliance Developer Netgate

    There is no "xd" there. Sounds like maybe there's a broken line in your /usr/local/etc/php/extensions.ini since it should probably be trying to load xdebug.so and not "xd".



  • I have attached a screen shot of the /usr/local/etc/php/extensions.ini file.

    Not sure what to make of this.  This file is not something that I would have directly made changes to myself.




  • I ended up wiping the machine and doing a fresh install of 2.3.2

    Along with the problems I had already mentioned, the update caused a lot of system instability and strangeness with the system.  I did not have time to troubleshoot and chase down all the issues I experienced, so a fresh install seemed like the best use of my time.

    After the install I restored to my backup config file I took before the update and now everything is pretty much back to normal (except for two traffic shaping rules I got alerts on which were not causing alerts in 2.2.6)

    On a side note, I was very happy with how well the restore backup config file worked.  I think next time there's an upgrade I will just wipe the system, install fresh and just restore the config file rather than going down the upgrade path.


Log in to reply