Microdrive 4Gb Hitachi & 8Gb Seagate - black art or what? [Solved]

  • Guys I'm trying to get Microdrives working with varying success. Why I've posted here will become clear in a second.

    I purchased an 8Gb Seagate and then booted a full install 1.2.1 CD. It saw the drive, installed fine but then on the re-boot just hung at post.

    So I searched the forum and there where many post saying Seagate's where poo get an Hitachi, So I did.

    The Install on the Hitachi went exactly the same - installed fine but froze at post. This time I just left it and bugger me it was booting just VERRRRRRRRRRRRRY slowly, in fact both drives work but you would have to leave them for a year to boot.

    So I went back to the forum and searched again and some bloke said you need to disable UDMA in the BIOS, PIO only. I did this and bang both drives boot! nearly all the way. The kernel loads all the hardware but then craps out when trying to load the driver for ad0 (the microdrive on the IDE bus), its complaining about LBA mode or something but I think I know why.

    When the CD loads and detects the microdrive the kernel on the CD detects the microdrive as PIO4 at boot and lets you install the OS but when you reboot off of the microdrive its self it is detected as UDMA33? and that is why its crapping out, why should this be if the kernel and OS on the CD are the same as what I've just installed to the microdrive?

    Please don't recommend I upgrade my BIOS, this thing would boot off a chocolate digestive if I asked it. I've just booted off a USB DVD-Rom drive to do a full install to a Sony micro vault but I don't know how long this will last! Please also don't recommend I change my card reader, it is designed for the case and if you actually look at one there is absolutly no logic on it what so ever, its just an IDE converter with a couple of resistors.

    Any help appreciated.


  • Hello,

    I have 2 Hitachi's both running on Alix, with full install. Having no problems at all. Followed the instructions on the full install. The editing in VI took most of my time, as a VI greenhorn.


  • @hansru:

    I have 2 Hitachi's both running on Alix, with full install. Having no problems at all. Followed the instructions on the full install. The editing in VI took most of my time, as a VI greenhorn.

    Err Yeh thanks for that - doesn't really help me!

    Anyway, found out that the /boot/loader.conf on the CD isn't the one that gets copied to the hard drive during install, the one on the CD has the line hw.ata.ata_dma=0 which is why the drive behaves during install but not on the reboot.

    So, I now have my microdrives working and this is what you may need to do,

    • Boot the 1.2.x install CD - Under FreeBSD 7 my USB DVD-ROM now works yey, it didn't under 6.2

    • Set LAN IP

    • Do a fresh full install (99) to your microdrive as if it where a real hard drive.

    • REBOOT (remove CD)

    (Microdrives don't like running at anything above PIO4 so in your PC BIOS Disable UDMA for IDE devices)
    If you don't do this you may not even be able to boot or you will get the spinnig cursor but it will spin REALLY slowly.

    Hit the space-bar when the kernel is loading (not at the Default F1 prompt) a little after, you should get an OK prompt.
    Then type;

    OK set hw.ata.ata_dma=0
    OK boot

    It should then boot all the way up to the pfsense menu.

    Drop to the shell by pressing 8

    Now edit /boot/loader.conf using vi;

    vi /boot/loader.conf

    Press the 'i' key and then move the cursor to the end of the last line and hit the enter key,
    add the line;

    so it looks like;


    then press Esc flowed by :wq

    Then press 'Ctrl D' to get back to the menu. Now you can restore your config by going to the web interface and quitting the wizard by clicking on the pfSense logo a couple of times.

    And the following reboot should boot fine without any kernel flags as you have already set them. If you restore your config before you have edited /boot/loader.conf you for some reason, on the subsequent reboots, can't input kernel flags and your install will be dead as you are now stuck in some weird catch 22.

    I hope this helps someone and for info the modified /boot/loader.conf survives a full upgrade.


  • cheesyboofs, I have a different problem in using Seagate 8GB microdrive. I have attached the drive via CF-to-IDE adapter to my computer for pfsense 1.2 install. The comuter Bios detects the drive, but pfsense install CD could not detect the drive and says that it could not find a suitable drive to install. Can you please tell me how you were able to install pfsense on 8Gb seagate microdrive ? Thanks for help.

  • The honest answer is I truly don’t know – By messing about in the BIOS with UDMA and PIO settings I was able to get pfsense installed once on the 8Gb Seagate but on subsequent re-installs as you say it failed to see the drive – it was at this point I gave up on the Seagate and purchased the 4Gb Hitachi and have never looked back, as others have stated stick to the Hitachi’s if you want a hassle free (almost) install.

  • Thanks for heads up. Hitachi 4GB microdrive works like charm. I was not able to get my 8GB  seagate microdive recognised by pfsens.

  • same here seagate won't work and magicstor is ok (i'll change in future to a hitachi)

    BTW: Anybody tried to use a ADM oder DOM e.g. in an alix board ?

    ciao gerd

  • Drop to the shell by pressing 8

    Now edit /boot/loader.conf using vi;

    though I can't test it…
    better configure your LAN IP, go to web itnterface, go to "edit file" and type /boot/loader.conf, LOAD  ::)

  • anyway you can point it out (twice)
    seagate does not work with pfsense….
    i double checked with 2x seagate and 2x hitachi.
    hitachi items are working but seagate fails on mounting rootfs because partition is not recongnized aqt startup..

    caio gerd

  • Hi

    Right now i'm using a Hitachi 30gb 2,5" drive on my alix 1.c. i had to use the hw.ata.ata_dma=0 switch. Before that i was trying to use a Seagate drive, but it would not work at all. everiting was working fine during install, but nothing would boot afterwards. seems that pfsense does not work well with the chf settings the alix bios passes.


Log in to reply