CARP with 16 public IPs. How am I seen from the internet?



  • Hello,
    I have a /28 public IPv4 class, and I already have configured two different public addresses for the WAN connection on my pfSense cluster, which has two nodes.
    I tryed to create a third VIP, with CARP, and I gave it another public IP. However, when I check what IP address I'm being using to browse the internet, it shows the one I have configured on the WAN side of the Master pfSense. I would like to use always the same IP instead, even if I use the Slave firewall. What am I doing wrong?



  • You have to change this in the outbound NAT settings on the master. Firewall > NAT > outbound.
    Select manual rule generation and hit save at first. The automatically generated rules should be preserved. Then edit the rule for your internal subnet and change the translation address to your CARP VIP.



  • Thank you VIragomann. I will try this as soon as the company opens again after summer break ;)


Log in to reply