LAN interface not working



  • Hi, I have a computer running pfSense as a router, it has 2 network cards, one of which is built into the motherboard, the motherboard network card is connected as the wan interface while my external 1Gb one is connect to a switch as the lan interface. Whenever the machine boots, i get a light on the switch indicating the card is running at 100Mb, this is only while booting. Once the machine has booted into pfSense, the switch shows no indication of being connected to the machine and the indicators on the network card are all off, the wan interface is working fine. Is there any way of fixing this? I've tried installing a previous version of pfSense and changing the PCI slot that the network card is in, none of which has worked.



  • You'll need to specify the motherboard model, the onboard NIC it has (look at the motherboard specs), as well as the make of the PCI NIC.

    FreeBSD can be finicky about NIC's, but loves Intel based ones.



  • I believe they're both intel based, however i'm not sure of the exact models because the hardware is old I never had the box. The thing is, it all worked fine before I upgraded to the latest version about two weeks ago, I've tried downgrading to the old version I had but it still doesn't work.


Log in to reply