Opção Allowed Subnets Squid 3



  • Alguém sabe dizer o que mudou na opção "Allowed Subnets" no squid2 e o  squid3?



  • Que eu saiba nada, está tendo algum problema?



  • Não sei se é um problema ou se mudou a forma de como se configurar essa opção. Na versão 2.7 do squid, quando você ativa o modo transparente, você precisa inserir as redes que tem permissão em "Allowed Subnets" de ter acesso ao proxy, já na versão 3 não é mais necessário configurar isso. Por isso perguntei se mudou alguma coisa.



  • Boa tarde,

    Nesta versão mais recente, percebi que a parte "Allowed Subnets" (de maneira geral) está apenas de "enfeite".  :-[

    Só funciona se marcar a flag "Allow Users on Interface" na configuração geral.

    Se você deixar desmarcado e colocar sua LAN em Allowed Subnets, não vai funcionar de jeito nenhum.

    Resumindo, é obrigado a marcar Allow Users on Interface.  ;)



  • Voce pode usar ela para permitir uma VPN por exemplo.



  • Mas o problema, Bruno, é que mesmo marcando essa a opção "Allow Users on Interface", você não precisa adicionar a rede que você quer que tenha permissão de acesso ao proxy em "Allowed Subnets". Eu realizei esse teste diversas vezes, só funcionou quando instalei a versão 2.7 do Squid.



  • Ou seja, mesmo eu não especificando a minha rede local, ela navegar normalmente pelo proxy transparente.



  • Boa tarde pessoal!

    Sei que o tópico é antigo, mas creio que abrir um novo para a mesma dúvida poluiria mais o fórum…

    Estou configurando um Squid 0.4.37 (não transparente) em um pfSense 2.3.4-RELEASE-p1 (amd64) e notei que mesmo com a opção "Allow Users on Interface" desmarcada na aba "General", e sem nenhuma rede em "Allowed Subnets" na aba ACLs, consigo navegar utilizando o proxy em meu navegador.

    Existe algum veredito final sobre o "Allowed Subnets"? Ele é realmente apenas um enfeite de gosto duvidoso, ou alguém encontrou alguma forma de fazê-lo interferir no comportamento do Squid? Adianta alguma coisa eu fazer o Update das versões do pfSense/Squid ou o comportamento persiste nas novas versões?



  • veja o squid.conf gerado pelo pacote para ver se ele está incluindo automaticamente as redes locais lá.



  • Obrigado pelo retorno marcelloc  :)

    Segue um grep do squid.conf filtrando pela string "access"

    grep access /usr/local/etc/squid/squid.conf

    access_log /var/squid/logs/access.log
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !safeports
    http_access deny CONNECT !sslports
    http_access allow localhost
    delay_access 1 allow allsrc

    Always allow access to whitelist domains

    http_access allow whitelist
    http_access deny sglog
    http_access deny allsrc

    A única coisa que encontrei liberando acesso para algo que possa remeter às minhas redes foi a linha destacada em negrito acima.

    Lendo a documentação eu não entendi que essa seja a função da diretiva "delay_access", mas eu posso ter interpretado errado.


Log in to reply