PPP with K3765 HSPA-USB-Modem | connection issue



  • Hi community,

    I am trying to get my K3765 HSPA-Stick running @ Pfsense 2.3.2

    It got detected and is offically supported and mentioned @ https://doc.pfsense.org/index.php/Known_Working_3G-4G_Modems

    Aug 16 22:06:08 kernel ugen1.2: <huawei technology="">at usbus1
    Aug 16 22:06:08 kernel u3g0: <huawei 0="" 2="" technology="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 0.00,="" addr="">on usbus1
    Aug 16 22:06:08 kernel u3g0: Found 4 ports.
    Aug 16 22:06:08 kernel umass0: <huawei 0="" 2="" technology="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 0.00,="" addr="">on usbus1
    Aug 16 22:06:08 kernel cd0 at umass-sim0 bus 0 scbus7 target 0 lun 0
    Aug 16 22:06:08 kernel umass1: cd0: <huawei 0="" 2="" technology="" huawei="" mobile,="" class="" 0,="" rev="" 2.00="" 0.00,="" addr="">on usbus1
    Aug 16 22:06:08 kernel <vodafone cd="" rom="" (huawei)="" 2.31="">Removable CD-ROM SCSI-2 device
    Aug 16 22:06:08 kernel cd0: 40.000MB/s transfers
    Aug 16 22:06:08 kernel cd0: Attempt to query device size failed: NOT READY, Medium not present
    Aug 16 22:06:08 kernel cd0: quirks=0x10<10_BYTE_ONLY>
    Aug 16 22:06:08 kernel da0 at umass-sim1 bus 1 scbus8 target 0 lun 0
    Aug 16 22:06:08 kernel da0: <vodafone storage="" (huawei)="" 2.31="">Removable Direct Access SCSI-2 device
    Aug 16 22:06:08 kernel da0: 40.000MB/s transfers
    Aug 16 22:06:08 kernel da0: Attempt to query device size failed: NOT READY, Medium not present
    Aug 16 22:06:08 kernel da0: quirks=0x2 <no_6_byte>##

    ugen1.2: <huawei mobile="" huawei="" technology="">at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (500mA)

    bLength = 0x0012
      bDescriptorType = 0x0001
      bcdUSB = 0x0200
      bDeviceClass = 0x0000  <probed by="" interface="" class="">bDeviceSubClass = 0x0000
      bDeviceProtocol = 0x0000
      bMaxPacketSize0 = 0x0040
      idVendor = 0x12d1
      idProduct = 0x1465
      bcdDevice = 0x0000
      iManufacturer = 0x0003  <huawei technology="">iProduct = 0x0002  <huawei mobile="">iSerialNumber = 0x0000  <no string="">bNumConfigurations = 0x0001

    and I was able to add it as Link Interface. I tried to connect all using "bug'n'trial" (/dev/cuaU2; /dev/cuaU0.0;/dev/cuaU0.1;/dev/cuaU0.2;/dev/cuaU0.3), but failed.
    Following the https://doc.pfsense.org/index.php/Configuring_3G_modems guide.

    Weird fact: There are totaly no log entries @ PPP log or general log according to connection attempts/fails. This log stays empty.

    Using

    Handle 0x0001, DMI type 1, 27 bytes
    System Information
            Manufacturer: Supermicro
            Product Name: X7SPA-HF

    dedicated for the Pfsense with its default USB 2.0 onboard ports

    Does anyone have some advice for me how to get the issue fixed?

    Thanks for your effort in advance.</no></huawei></huawei></probed></huawei></no_6_byte></vodafone></vodafone></huawei></huawei></huawei></huawei>



  • Hi,

    okay - found the issue…

    using /dev/cuaU0.0

    and if I want to use this interface, I should also tick the "hidden" checkbox "enable interface" :-D

    --
    closed ;-)


Log in to reply