SMTP service for notifications



  • I am having trouble using Google's SMTP service to send notification emails. Any suggestions for a free, non-authorization, SMTP relay?



  • Hi, well if you want use google smtp for notification, first you have configre you account in Google Apps and add your ip public and before you can use the address smtp-relay.gmail.com with port 25, all this is not work for the account free of gmail this not is administrable,



  • @cobrahead:

    Any suggestions for a free, non-authorization, SMTP relay?

    Reputable non authenticated/authorized SMTP relays (aka open relays) are pretty much gone from the world. Too prone to abuse.

    There are lists of open relays to be found, but most admins use these lists to block inbound SMTP connections as part of spam controls.


  • Rebel Alliance Developer Netgate

    Ask your ISP if they have one, though almost all of them require auth and the use of port 587 now, few if any remain that allow open relay on 25 even inside their own networks.



  • Setup Email Notifications using the Google Gmail SMTP service.  I am posting this information in an effort to help or save someone else time.

    E-Mail Server: smtp.gmail.com
    SMTP Port of E-Mail server: 465
    Secure SMTP Connection: Checked
    From e-mail address: <email address="">@gmail.com account and have left the field blank - both options work
    Notification E-Mail address: <email address="">@gmail.com
    Notification E-Mail auth password: Need to use a Google Gmail App Password NOT your login password
    Notification E-Mail auth mechanism: PLAIN

    Log Entries:
    Aug 19 19:23:29 php-fpm 86995 /system_advanced_notifications.php: Could not send the message to <email address="">@gmail.com – Error: 534-5.7.9 Application-specific password required. Learn more at

    The above error was caused by using the standard login password.  Rather the password needs to be a Google "App Password" created specifically for pfSense

    Some additional Information:
    Google SMTP: https://support.google.com/a/answer/176600?hl=en
    Google App Password: https://support.google.com/accounts/answer/185833?hl=en</email></email></email>



  • @dtheimer:

    Setup Email Notifications using the Google Gmail SMTP service.  I am posting this information in an effort to help or save someone else time.

    E-Mail Server: smtp.gmail.com
    SMTP Port of E-Mail server: 465
    Secure SMTP Connection: Checked
    From e-mail address: <email address="">@gmail.com account and have left the field blank - both options work
    Notification E-Mail address: <email address="">@gmail.com
    Notification E-Mail auth password: Need to use a Google Gmail App Password NOT your login password
    Notification E-Mail auth mechanism: PLAIN

    Log Entries:
    Aug 19 19:23:29 php-fpm 86995 /system_advanced_notifications.php: Could not send the message to <email address="">@gmail.com – Error: 534-5.7.9 Application-specific password required. Learn more at

    The above error was caused by using the standard login password.  Rather the password needs to be a Google "App Password" created specifically for pfSense

    Some additional Information:
    Google SMTP: https://support.google.com/a/answer/176600?hl=en
    Google App Password: https://support.google.com/accounts/answer/185833?hl=en</email></email></email>

    That did the trick!


Log in to reply