Alix not finishing boot



  • Hello,

    I tried sevral version on an alix ans every time same thing :

    I can assign the lan , wan, … I apply the changes then the machine boots and it hangs after "starting DHCP...done" (second time)

    (See below )

    I tried several 1.2 and 1.3 and got the same problem

    Any idea welcome !

    Thank you

    ___/

    Welcome to pfSense 1.2.1-RC1 on the 'embedded' platform...

    Setting up embedded specific environment... done.
    Mounting filesystems... done.
    Creating symlinks......done.
    Launching PHP init system... done.
    Initializing.................. done.
    Starting device manager (devd)...done.
    Loading configuration......done.

    Network interface mismatch -- Running interface assignment option.

    Valid interfaces are:

    vr0    00:0d:b9:12:78:78
    vr1    00:0d:b9:12:78:79
    vr2    00:0d:b9:12:78:7a
    ath0    00:19:e0:63:b3:87

    Do you want to set up VLANs first?
    If you are not going to use VLANs, or only for optional interfaces, you should
    say no here and use the webConfigurator to configure VLANs later, if required.

    Do you want to set up VLANs now [y|n]?n

    NOTE  pfSense requires AT LEAST 2 assigned interfaces to function.
            If you do not have two interfaces you CANNOT continue.

    If you do not have at least two REAL network interface cards
            or one interface with multiple VLANs then pfSense WILL NOT
            function correctly.

    If you do not know the names of your interfaces, you may choose to use
    auto-detection. In that case, disconnect all interfaces now before
    hitting 'a' to initiate auto detection.

    Enter the LAN interface name or 'a' for auto-detection: vr0

    Enter the WAN interface name or 'a' for auto-detection: vr1

    Enter the Optional 1 interface name or 'a' for auto-detection
    (or nothing if finished):

    The interfaces will be assigned as follows:

    LAN  -> vr0
    WAN  -> vr1

    Do you want to proceed [y|n]?y

    Updating configuration…done.
    Cleaning backup cache...done.
    Setting up extended sysctls...done.
    Syncing user passwords...done.
    Starting Secure Shell Services...done.
    Setting timezone...done.
    Starting syslog...done.
    Configuring LAN interface...done.
    Configuring WAN interface...done.
    Configuring OPT interfaces...done.
    Configuring CARP interfaces...done.
    Syncing system time before startup...done.
    vr1: vr_stop: Rx shutdown error
    vr1: Using force reset command.
    Configuring firewall......done.
    Starting webConfigurator...done.
    Starting DHCP service...done.
    Starting DNS forwarder...done.
    Setting up microcode and tx/rx offloading...done.
    Starting FTP helpers...done.
    Final filter pass......done.
    Generating RRD graphs...done.
    Starting DHCP service...done.



  • I've come across this issue and this is a simple issue to resolve. The issue is with the BIOS revision the ALIX board is running. I bought a ton of ALIX boards and they all came with version 0.92 firmware. This is fine for monowall but not for pfSense. Get an empty CF card handy and go here: http://pcengines.ch/alix2.htm to download the freedos based 0.99 bios update. If you use physdiskwrite.exe to copy the .img file here: http://pcengines.ch/file/freedos.zip (inside the zip file) you can then copy the 0.99 files to the CF card in windows. Boot to the CF card, run "sb" at the command prompt to upgrade and you should now be able to run version 1.2 images and up on ALIX.


Log in to reply