Problems after change IPs - help me…



  • Hello

    I have a VM (PFSense version 2.3.2) and it was with IP WAN 192.168.0.42 and LAN 192.168.0.109.
    Everything worked fine.
    I changed the IP WAN 192.168.0.42 and LAN 192.168.0.223 so the workstations stopping navegate.
    Then I back to the to old IP.
    Now, if I ping the internet, ok, answer with sucess. If I the internal network, doesn't answer.

    What could be wrong?



  • First off, you didn't show your netmasks but you have your WAN and LAN in the same network, which is a big no-no.  You're lucky it worked at all.  If it is acting as a gateway and you change the LAN IP address, you should not be surprised to find that your LAN clients have no Internet access.



  • Tks for the answer.
    But why it works when you configurate in OS Linux?
    I already started Proxies (Squid) where the interfaces, eth0 and eth1 weren't at the same network 192.168.0.X and worked fine.
    By the way, I'm began to work with PFsense only 10 days ago.
    Backing to the problem, once the LAN takes IP 192.168.1.1 , I can ping internet and internal network.
    But, how will I access the dashboard if the network are diferent (192.168.0.X x 192.168.1.X)?



  • @aapa_05:

    But, how will I access the dashboard if the network are diferent (192.168.0.X x 192.168.1.X)?

    From the LAN IP.

    LAN 192.168.0.109 or LAN 192.168.0.223  whatever your LAN IP is currently.


  • LAYER 8 Global Moderator

    "But why it works when you configurate in OS Linux?"

    I don't know what your doing in linux but in routing you do not put the SAME network on different interfaces that go different places..

    If your wan of pfsense is behind a nat already and is in the 192.168.0/24 network - then use something else on your lan side be it 192.168.1/24 172.16.0/24, something other than 192.168.0/24

    As to how you would access pfsense web gui, well you would need to be on that network.. If you use 172.16.0/24 then ALL your devices on that specific network segment behind pfsense would be on that same network..



  • Hi everybody
    Maybe if I explain my problem since begin and you could help me.
    I have a Sonicwall, like firewall, gateway and filtering internet.
    The link (data) enter on it with IP 200.X.X.X (WAN), the internal IP is 192.168.0.254/255.255.255.0. It has some groups, been that the IP groups 192.168.0.1 to 192.168.0.50 has total access to internet ( reserved to managers, supervisors, servers) .
    The IPs 192.168.0.51 to 192.168.0.150 are dedicated to the other workstation, access controlated.
    Sonicwall has a annual maintenance coust (expensive) and we don’t want to spend with it.
    So I searched other solutions, like Linux or PFSense.
    On linux (installed on VM), the WAN takes a IP between x.x.x.1 to x.x.x.50 and the LAN x.x.x.229.
    Squid works fine with it, but the firewall is complicated to configurate a little more.
    Then I started a PFSense section (also on VM), with IP WAN x.x.x.42/24 and IP LAN x.x.x.109/24
    Everything worked find until I change the IP Lan to x.x.x.100/24. So I back to the old IP.
    Still so, doesn’t work.
    I understood that the IP wan cannot be on the same network, but is there anything I can do?
    Example, creating a routing…
    How could worked once?

    Tks



  • It's not important why it seemed to have worked in the past.
    Johnpoz already described how to set it up correctly. Use that and create a working system, don't you think?

    BTW: you can create your "groups" with "aliases" in pfSense.


Log in to reply