Projeto de Wifi com autenticação



  • Olá amigos, eu estou encarregado de um projeto de Wifi com autenticação pelo portal cativo, estou com um link de 50mb da gvt com ip dinamico, e queria fazer o DHCP no Pfsense, mas nao estou conseguindo fazer isso.

    Na porta WAN do firewall eu coloco 192.168.25.1
    Print 1

    Na porta LAN eu faço o seguinte
    Print 2

    Mas a internet não funciona, eu nao entendo se eu deixo o DHCP no moden ou desabilito o DHCP do moden e faço pelo Pfsense.

    Quem puder me ajudar estarei muito agradecido.



  • Não está correto da forma que você fez, o link da GVT você liga na porta WAN do Pfsense, essa placa voce deixa para receber o IP automaticamente da GVT.

    Na Lan você configura o IP interno (192.168.25.1) e configura o DHCP para entregar o IP para seus clientes internos.



  • ola, eu configurei dessa forma aqui.
    WAN > deixei pegar o link automaticamente 192.168.25.17/24
    LAN > 10.0.0.1/16
    10.0.0.0
    Start 10.0.0.1 - End 10.0.255.254

    o ping pra a wan funciona, mas pra redes externas nao tipo 8.8.8.8
    mesmo assim a conexão nao funciona, preciso fazer algo a mais ?



  • Precisa ir em System: General Setup  e determinar o servidor dns e ativar o serviço em Services: DNS forwarder.



  • Minhas regras estão assim, oque eu devo mexer para resolver.


    Muito obrigado pela ajuda.



  • Como ta teu DHCP Server? Tem quantas interface nesse teu pfsense? Teu Fire tá em alguma rede local (interna?)



  • Minha interface WAN é : 192.168.25.17/24 (É pego automaticamente pelo pfsense do meu link da gvt)
    Minha LAN : IP ADRESS 172.16.0.1 > Gateway 172.16.0.0 - Cliente start 172.16.0.2 End 172.16.255.254

    Somente tem essas interfaces.



  • Quem tu quer pra ser teu DHCP? Pelo o que eu to achando ta tendo um conflito de DHCP na tua rede. O teu Cliente Start, o cabo ta na porta WAN ou LAN?



  • no caso meu start cliente ta na LAN, e minha WAN pega o DHCP4 automaticamente. O pfsense so tem acesso a net quando eu reinstalo e ele instala tudo automaticamente, depois que eu mudo o lan para /16 ele para de funcionar.

    Ai fica asim:
    IP Adress 172.16.0.1
    Mascara /16
    NAT gateway 172.16.0.0
    start 172.16.0.1 end 172.16.255.254

    isso na interface LAN.



  • Tu já tentou setar ele direto no console? Desabilita o DHCP do teu cliente e deixa apenas no PFsense. Ou faz assim, monta uma rede fora todo esse teu cenário e faz as configurações sem com cliente conectado nele, apenas o pfsense um hub e um computador e ver se o computador pega IP do DHCP do pfsense.



  • Amigo testei ele do zero, quando o LAN e WAN ficam estáticos a conexão funciona, mas quando eu faco o dhcp na LAN o pc pega o ip, mas nao funciona a internet.



  • @Chephei:

    Amigo testei ele do zero, quando o LAN e WAN ficam estáticos a conexão funciona, mas quando eu faco o dhcp na LAN o pc pega o ip, mas nao funciona a internet.

    Boa noite,

    Qual teu cenário atual? Quantos links estão alimentando seu PfSense.
    Tive um problema essa semana com um powerbox GVT e consegui configurar o pfsense para fazer a autenticação PPPoE, depois disso o link ficou estável e consigo configurar qualquer máquina para sair pelo gateway criado.

    Consegue me elucidar sobre teu cenário para que eu veja se foi a mesmas situação que enfrentei?
    Assim posso tentar te ajudar



  • Consegui resolver meu problema, não era a porta wan, eu deixei o pfsense pegar o seguinte ip do powerbox da gvt 192.168.25.17/24 (IPV4 Statico), o erro era meu calculo de subnet da porta LAN.

    minha LAN que funcionou agora com os seguintes ips

    E funcionou tudo perfeitamente, so apenas meu portal cativo esta um pouco lento na navegação, oque posso fazer para melhorar isso ?



  • O problema todo era a questão da mascara, certo? Ver tua placa de rede.



  • sim, somente a mascara 17 funcionou. outras como 16 e 8 não. Se alguém souber porque, favor comentar. e muito obrigado a todos.



  • Boa noite,

    Voce estava usando um endereço de rede como gateway?

    Estava querendo consultas de dns para o 172.16.0.1 saindo por 192.168.25.1?

    Rede 172.16.0.0/16
    broadcast 172.16.255.255,
    Gateway pode ser qualquer um entre 172.16.0.1 a 172.16.255.254
    DHCP pode ter o ranger entre 172.16.0.1 a 172.16.255.254, pulando o gateway é claro.

    Ficou meio estranho mas espero que que voce tenha resolvido seu problema.