Munin-node package for 2.3?



  • I've been looking for a munin-node package to monitor my GW. Most threads dates a few years back and information is sparse.

    Is there any munin-node pacakge for pfsense 2.3? Or is there an alternative way?

    Thanks in advance,
    jkaberg



  • Hi,

    there is still no package munin-node for pfSense 2.3, but I did it this way (although it is not recommended, see: https://doc.pfsense.org/index.php/Installing_FreeBSD_Packages):

    • Enable FreeBSD repo - comment the lines saying "FreeBSD: { enabled: no  }" in both files "/usr/local/etc/pkg/repos/FreeBSD.conf" and "/usr/local/etc/pkg/repos/pfSense.conf"

    • Install package - pkg update && pkg install munin-node

    • Change PID file path - in the munin-node config file "/usr/local/etc/munin/munin-node.conf" change the line "pid_file /var/run/munin/munin-node.pid" to "pid_file /var/run/munin-node.pid"

    • Enable autostart:

      • pfSense startup script must end with ".sh" - ln -s /usr/local/etc/rc.d/munin-node /usr/local/etc/rc.d/munin-node.sh

      • pfSense uses action "start", so regular starting must be allowed - echo 'munin_node_enable="YES"' >> /etc/rc.conf.local

    • Disable FreeBSD repo (rollback the first step)

    Debug output of pfSense rc.d scripts starting is in the file "/tmp/bootup_messages".

    I am not pfSense nor FreeBSD guru, your notices are welcome!

    D.



  • How do you open port 4949 on the pfSense so that munin-node can be polled by the munin master?



  • Hi,

    Now that is a strange question.
    You are using pfSense, right ? It's (also) a firewall.
    So, do the firewall-thing and you're ok.

    The question isn't complete, because
    If your munin master is running on pfSEnse, nothing do 'open' - it's a home (localhost) issue.
    If the munin master runs on a device on the LAN, nothing to do, the default LAN firewall rule will let traffic go through.
    If the munin master runs on a device on some OPTx interface : see the next situation :
    If the munin master runs on some device some where on the Internet, well, then it hits against the WAN firewall block all rule. So, make a rule and you're ok.

    My case is the last one, so I had to add this firewall rul on the WAN interface : see image.

    The source alias "SYSx" is an alias for the IPv4 of the munin master host - the rest is pretty obvious.




  • Thank you Gertjan and apologies for my rather clueless question. The munin master is within the LAN. Indeed, I have set up the node as described above, and everything now runs as it should. Sorry again for being a bit dumb…