[SOLVED] cannot ping WAN port



  • Hey all,

    I just installed pfsense on a supermicro H7SPE and have everything setup fairly easily. Problem is I can't seem to ping the WAN port.

    This is how I have setup for testing:

    LAN = 10.0.10.21/24
    WAN = 10.0.0.21/24

    PC1 = 10.0.10.20/24 (using this for webconfig)
    PC2 = 10.0.0.20/24

    PC1 -> LAN port –- PFSENSE --- WAN port <- PC2

    I am just trying to test basic pass through so that I can move on to the actual real firewall setup.

    I can ping the LAN port just fine and have been using the webconfig, but I can't ping the WAN port, let along get any pass-through across networks. I have tried to login to the webconfig from the WAN side to see if that works, (it didn't) as you know ping can sometimes not work due to design so I thought that might work.

    I have also tried running the WAN port through my local network and setting up a dfgw but that didn't work either. So then just went back to patching straight into the machine.

    Also there is nothing in the system logs to indicate any ping action, that also goes for the LAN port which is working just fine. So that doesn't really help much.

    I have attached two photos pertaining to my WAN/LAN rules.

    I have also seen this thread on the topic:

    https://forum.pfsense.org/index.php?topic=67890.0

    None of the suggestions worked.

    Any help would be greatly appreciated.

    Thanks in advance
    MedicineMan25




  • LAYER 8 Global Moderator

    So how would source lan ever be an input into your wan interface? The complete lack of logic when people start clicking on shit just blows my mind ;)

    So did you turn off nat? if your going to be using this internally.  If then you have to create port forward not just open up a firewall rule.

    There are lots of threads of users not able to figure out the click click of a port forward..

    https://doc.pfsense.org/index.php/How_can_I_forward_ports_with_pfSense
    https://doc.pfsense.org/index.php/Port_Forward_Troubleshooting

    As to not able to ping your pfsense wan – you have no rule that allows icmp to your wan address so yeah its not going to ping..



  • So how would source lan ever be an input into your wan interface? The complete lack of logic when people start clicking on shit just blows my mind ;)

    hahaha, yeh I'm pretty fresh with hardcore firewalling and networking in general. I understand the principles and I've run some pretty massive AV/automation networks in the past, but never had to actually build anything from scratch like this before and never more than what is needed for an AV/automate network. The most advanced things I did were: configure a few VLANS, tag/untagged some ports, turn on IGMP snooping for multicast traffic and setup some static routes, forwarded some ports, setup a basic snmp and a winbox terminal. that's just about it in terms of actual networking. Plus the routers we were using weren't exactly cisco so turning on icmp is simply nothing I have ever thought was necessary. Cool basic feature though, especially for a firewall.

    So the logic there was that I want source LAN to destination WAN, I hadn't started testing that so that doesn't really matter for this…. but of course; port forwarding. that would've fuckd me. silly brain. thanks.

    I've added an ICMP rule to my WAN port (will take it off when finished testing) and whatayaknow; it pings. like I said, I really didn't expect that to be something needing configuration. It seems I have drastically under-estimated the amount of control allowed in pfsense, now that I know that I have a much broader scope of what is possible and what needs consideration.

    So did you turn off nat? if your going to be using this internally.  If then you have to create port forward not just open up a firewall rule.

    oops… it's turned off now... yeh, so all good with the port forwarding. Thanks though, I will definitely have a re-think of how I approach this project now that I have completed the initial fresh-project-sanity-check phase.

    Thanks so much for the reply, really appreciate the input!

    MedicineMan25


Log in to reply