Intel X710-DA4 driver/NVM version mismatch?


  • I just installed an Intel X710-DA4 on a pfSense machine and noticed the ixl driver complaining in dmesg about the NVM image being older than expected, so I installed the most recent version of the NVM from Intel's site (version 5.04, I think). Now the ixl driver is complaining that the NVM is too new:

    
    ixl0: <intel(r) ethernet="" connection="" xl710="" driver,="" version="" -="" 1.4.3="">mem 0x383ffe000000-0x383ffe7fffff,0x383fff018000-0x383fff01ffff irq 16 at device 0.0 on pci5
    ixl0: Using MSIX interrupts with 17 vectors
    ixl0: f5.0 a1.5 n05.04 e800024cd
    ixl0: The driver for the device detected a newer version of the NVM image than expected.
    Please install the most recent version of the network driver.
    ixl0: Using defaults for TSO: 65518/35/2048
    ixl0: Ethernet address: 3c:fd:fe:9c:7b:a0
    ixl0: PCI Express Bus: Speed 8.0GT/s Width x8
    queues is 0xfffffe000106a000
    ixl0: netmap queues/slots: TX 16/1024, RX 16/1024</intel(r)> 
    

    How big of a deal is this? What version of the NVM is the driver expecting? Intel has an NVM downgrade utility available, but I'd rather not just downgrade randomly until I find the right version that the driver is expecting. Should I update the driver itself?


  • Okay, so an update:

    1. I tried to downgrade the NVM, but it appears that I was mistaken about the availability of NVM downgrade tools for the X710 series. Looks like I'm stuck with NVM 5.04.

    2. I looked into upgrading my ixl drivers. It was easy enough to build the newest version of the Intel ixl drivers on a FreeBSD 10.3 VM, but it appears that I can't load the new module because the ixl driver that comes with pfSense is statically linked into the kernel.

    It appears that I'm stuck with this NVM/driver mismatch, unless I want to build my own pfSense kernel without a statically linked ixl driver. Again, does anybody know if this mismatch is a serious issue? The card seems to be working fine, except that it seems to take an inordinately long time after boot (several minutes) for the interface to be responsive. Cursory iperf tests show the card is capable of 10g line speed without any additional tuning.


  • Hi allan,
    I am interested in functionality of the network cards based on XL710-AM1.
    You can confirm that with pfSense 2.3 work without problems?

    Thank you


  • Hi Allan,

    How did you install the drivers for X710 in pfSense? I was trying to do the "make install" as per the README file after downloading the driver from Intel's website, but was unable to do so because of compiler error. I tried installing gcc, but that didn't help either. Please help.

  • Netgate Administrator

    Are you seeing a version mismatch like the OP or no driver at all?

    What error are you seeing?

    Steve

    Edit: Nevermind I see your other thread. This is issue is unrelated.