Problems with fxp on Soekris 4801



  • I don't know - is it related to FreeBsd 6.1 RC build or something else, but i obsrved following problem:
    on soekris net4801 board with Intel Pro100+ adapter installed in PCI slot system hangs in strange ways.

    when copying hughe files from (some network resource) -> fxp0 (wan) -> local disk ata1 : everything works perfect,
    when copying hughe files from (some network resource) -> fxp0 (wan) -> sis0…2 : - system hangs after 2..3..10 megabytes copied,
    when copying hughe files from (some network resource) -> fxp0 (wan) -> ath0 : - the same, system hangs after 2..3..10 megabytes copied,

    I tried to change intel adapter to other one (the same model) - system hangs in the same way, so i think - adapter is in working condition.

    so I bought brand new 3com 905cx-tx-m adapter - that's solved my problem!

    Byt the question is: why fxp driver starts to produce so strange glitches on soekris? Before beta3 upgrade i did not observe such problem.
    May be someone can help me with this, - or some new "unexpected behaviour" is introduced in fxp0 driver?

    Thanks for help,
    Arnis



  • Might be a powers supply issue. Check if your powersupply matches the additional card/load.



  • It probably is power supply related.  The ones that ship with the Soekris boxes can barely handle the unit itself (12v @1A if I recall).  I went to Radio Crap er Shack and picked up a 15V @1.5A for my WRAPs - the Soekris should handle the same supply.  12-18V if I remember correctly.  I've seen 4801's lock up with the original supply (and you'll see that on the Soekris lists too).

    –Bill


Log in to reply