Addition DHCP options not getting sent to additional pools



  • I have some IP phones that rely on some additional DHCP options for them to pull their config. I have created a secondary address pool and used mac address prefixes to force the phones to pull IPs from this additional pool. The phone boots and gets an IP from the correct pool but it is not receiving the extra DHCP options which I configured in this additional pool.

    Is this a known bug and if so, is there a work arround?



  • Out of curiosity I set my custom VoIP phone options in the main pool and now the phone is getting an IP from the second pool and getting the custom options from the main pool. Idealy I don't want the DHCP options from the main pool going out to all pools. The additional pools should be getting their own options.



  • So can someone acknowledge this bug? It would be nice to see this fixed so we can actually deploy custom DHCP options to secondary pools.


  • Rebel Alliance Global Moderator

    why do you not just sniff on the dhcp exchange to see what you get.  They we would all know for sure what is happening.  There was a somewhat sim thread about dns servers not being handed out via dhcp reservation.  I tried to duplicate that and was not seeing the problem, and you could see right off in the dhcp offer sent by the dhcp server running on pfsense that it sent the information.

    I could try and duplicate your secondary pool, and put in some sort of options in that pool that is not in the main pool.  Could you give a specific example of the options you want to hand out so I can try and duplicate as close as possible to what your seeing.



  • This is what I have in my main scope. If I remove these options from the main scope and only place them on the secondary pool, the options are not passed to the phones. The phones do infact get an IP from the second pool though. If I put these options in the main pool, the phones get an IP from the second pool but the options come from the main pool.


  • Rebel Alliance Global Moderator

    Well I can say I seem to see the same problem from quick test.  I created an additional pool, denied my boxes mac on the normal pool, and put those options in on the added pool settings.  I then did a release and renew of my IP and did get a new Pool IP, but in the sniff I did not see any of those options in the offer.

    So this seems to be a known issue
    https://redmine.pfsense.org/issues/6720

    And there is a fix for it.  https://redmine.pfsense.org/projects/pfsense/repository/revisions/285987208f31f38abe35b984b08645d43c11b001

    You could apply that or wait til pfsense updates and includes that fix.