LoadBalance + Failover + Problema Banco do Brasil



  • Boa tarde a todos.

    Estou em uma situação que não achei solução ainda neste forum, apesar de ver assuntos semelhantes.

    Meu server está configurado para fazer loadbalance a moda antiga, sem usar o recurso loadbalance já presente na versao 2.3. Fiz indo em Gateways, deifnindo eles, depois criando 03 grupos, um de loadbalance, um de failover da primeira para segunda e um de failover da segunda para primeira. Fui em firewall>rules> e habilitei 03 regras para lan lannet passando cada um por um gateway criado nos grupos de rotas. Funciona perfeito o loadbalance e o failover mas o problema tem sido o banco do Brasil. Quando eu deixo só no failover funciona, mas quando configuro o loadbalance o banco cai, trava e não tem jeito.

    Procurei soluções mas ainda nao consegui manter o loadbalance e acessar o banco do Brasil. ALguem poderia realmente me dar um Help? Estou com esse problema em todos os PFs com loadbalance ativo que acessam o BB.

    desde já agradeço qualquer tentativa de ajuda.



  • Eu faria duas coisas:

    1 - Vai em advanced /micellaneous e marque Use sticky connections
    2 - (tive que fazer isso quando deixei mais de umm IP na saída )vai nas configurações de NAT / oubound e edite a regra que contem os IPs de saída e em pool options selecione round Robin with sticky address (as vezes será necessário deixar Nat manual )



  • Cria uma regra LAN - > 170.66.0.0/16 somente failover

    Segue como descobri a rede do BB

    http://bgp.he.net/ip/170.66.2.59

    AS11993 170.66.0.0/16 BANCO DO BRASIL S.A.

    Retorna se deu certo.



  • @maxwelber:

    Cria uma regra LAN - > 170.66.0.0/16 somente failover

    Segue como descobri a rede do BB

    http://bgp.he.net/ip/170.66.2.59

    AS11993 170.66.0.0/16 BANCO DO BRASIL S.A.

    Retorna se deu certo.

    Poderia me exemplificar melhor como fazer esse procedimento por favor?



  • Faça uma regra de saida de https para um Gateway da sua wan que o problema do banco do brasil é resolvido.




  • Mas pelo que entendi do jeito que vc explicou todo tráfego https sairá por apenas uma net certo? Eu gostaria que fosse apenas o BB. Tem como?



  • @deivison90:

    Mas pelo que entendi do jeito que vc explicou todo tráfego https sairá por apenas uma net certo? Eu gostaria que fosse apenas o BB. Tem como?

    Basta vc criar uma regra Aliases com o endereço e efetuar o mesmo processo



  • Consigo tbm definir que um ip específico da lan, ou um mac, não use o loadbalance apenas failover?



  • @deivison90:

    Consigo tbm definir que um ip específico da lan, ou um mac, não use o loadbalance apenas failover?

    Consegue sim…. crie uma regra baseda na que vc já possui de FAILOVER, então é só alterar nesta regra, especificando a origem como sendo o micro que vc deseja (ao invés de LAN NET)... lembrando de que esta regra vc deverá mover para antes das outras (principalmente para antes da regra de LOADBALANCE) senão o micro em questão continuará caindo no balanceamento.



  • @fernandofolha:

    @deivison90:

    Consigo tbm definir que um ip específico da lan, ou um mac, não use o loadbalance apenas failover?

    Consegue sim…. crie uma regra baseda na que vc já possui de FAILOVER, então é só alterar nesta regra, especificando a origem como sendo o micro que vc deseja (ao invés de LAN NET)... lembrando de que esta regra vc deverá mover para antes das outras (principalmente para antes da regra de LOADBALANCE) senão o micro em questão continuará caindo no balanceamento.

    Obrigado pela resposta foi grande valor. Mas me gerou uma dúvida. As regras não são executadas de cima para baixo? Sendo assim se eu fizer como vc sugeriu, a regra do loadbalance ficando após a regra como vc orientou não sobrescreveria a outra?

    @maxwelber:

    Cria uma regra LAN - > 170.66.0.0/16 somente failover

    Segue como descobri a rede do BB

    http://bgp.he.net/ip/170.66.2.59

    AS11993 170.66.0.0/16 BANCO DO BRASIL S.A.

    Retorna se deu certo.

    Poderia me explicar como fazer, ainda não entendi.



  • Cara resolvi esse problema colocando no firewall para passar por apenas uma conexão quando acessa o site da caixa e BB.



  • Poderia me dizer como fazer?





  • @rlrobs:

    Eu faria duas coisas:

    1 - Vai em advanced /micellaneous e marque Use sticky connections
    2 - (tive que fazer isso quando deixei mais de umm IP na saída )vai nas configurações de NAT / oubound e edite a regra que contem os IPs de saída e em pool options selecione round Robin with sticky address (as vezes será necessário deixar Nat manual )

    No meu caso só o passo 1 já resolveu (Use sticky connections)