Hang on 'synchronizing user settings hang' after updating from 2.3.1 to 2.3.2


  • I'm after upgrading  my pfSense box from 2.3.1 to 2.3.2 the boot process hangs at "Synchronizing user settings…"
    So I got a hint from https://forum.pfsense.org/index.php?topic=80247.0 and tried playing around with the <user>& <group>settings in the config.xml

    Sure enough, if I comment out all the <user>settings in the config.xml, save the file and reboot, my pfSense box boots into 2.3.2 just fine.

    I then tried creating a user from the WebGUI, but when I do and reboot the box it hangs yet again at "Synchronizing user settings…" until I comment out the new user I just added.

    Is there anything  that has changed between releases affecting users/groups?  I can reproduce this issue every time on my current set-up. But I can't believe I'm the only one experiencing this issue either.

    Help appreciated!</user></group></user>


  • Just to follow-up on this.
    I ended up resetting the configuration completely and rebuilding it.
    The issue went away after that.

  • Rebel Alliance Developer Netgate

    Do you still have a backup of that config with the users and groups? I'd be very curious to see what might have caused that.