Serial cable for x550e



  • Hello,

    I am trying to install pfSense on a WatchGuard x550e. I am stuck on flashing the BIOS - I don't get anything on serial console. I suspect this may be due to using a wrong cable. When booting off a Lexar 128MB CF card with the FreeDOS and BIOS update tool, I hear the 3 beeps, but the console doesn't output anything. As advised, I am trying to connect at 9600 baud, 8 data bits, 1 stop bit, no parity. Additionally, the CMOS battery (CR2032) was not installed while I was experimenting (the one that was installed when I got the unit was completely flat, and I haven't got any replacement on hand).

    I have tested two cables: One which only uses pins 2,3 (crossed) and 5 (straight-through), and one which additionally uses pins 7 and 8 (crossed). I am using PuTTY on Windows. I tested the cables and serial ports of the machine (it has 2) by connecting them with the cable and starting 2 PuTTY instances - I set them to 9600 baud, 8 data bits, 1 stop bit, no parity, XON/XOFF flow control. The communication between them worked OK.

    Does the x550e require a different type of serial cable?



  • Try using a diffrent program like teraterm. Sometimes for me Putty just randomly does not work. And as far as I know, to get into the BIOS on x550e you need 115200 baud rate. 9600 baud rate is only once you get into Pfsense.. However that is only with older versions. latest PFsense does not use 9600 anymore as far as i know, it uses 115200.



  • I am stuck at flashing the BIOS:
    https://doc.pfsense.org/index.php/PfSense_on_Watchguard_Firebox#Flashing_the_BIOS
    The doc clearly says 9600, 8 data bits, 1 stop bit (or am I reading the 9600 8N1 wrong?). I am not getting anything on the serial console. I get 3 beeps, but the console stays blank. I tried using another PC for connecting, but nothing has changed.



  • The cable you use must be capable of full handshaking.

    I believe this is the one I built for myself.

    http://www.automation-world.com/img/automation_1/ig/9-pin-null-modem-cable_db9nullxover.gif



  • Thanks, chpalmer, that worked!

    Now a bit different problem: Using the same cable you linked, I can't get into BIOS. I only get gibberish on the screen (behaving like a wrong speed is set). Of course, I switched the speed to 115200 8N1.

    Edit: Re-made the serial cable with proper shielding, that has done the job. All problems solved.