NAT port 21 not working (Ver 2.3.1-5)



  • I have spent all day trying to get a NAT to port 21 working but to no avail.

    When I connect to the WAN interface using 4G on my phone, I can get the logon screen but then it fails to actually complete the process.  When I use the same FTP client on the same phone but with WiFi the connection works fine.

    I thought it might have been the server for some reason, so I tried to connect to a different FTP server on different hardware and both display the exact same behaviour.

    I then thought it must be my config so I tried it with two different (VirtualBox test configurations) http servers by changing only the target internal IP address: Port service and that worked flawlessly both times.

    The States table appears to show that the port is being correctly redirected too.

    Anyone ANY ideas?



  • I have just seen the 'sticky' above on this very subject.  I missed it earlier, I will have a read of that.  I am guessing it will address my issues.



  • That explains it exactly … Problem solved.