Unbound slows when VPN gateway interface activated (XPOST Routing and Multi WAN)



  • Hello,

    I have both a WAN and VPN gateway on my pfSense host. When I activate the interface for the VPN gateway DNS queries slow to a crawl. I expect this is because unbound starts routing requests over it, which I have tried everything I can think of to prevent:




    Despite all of this if I enable the VPN interface DNS crawls. Anything else I can check?

    Thanks!



  • Do you need to use the DNS resolver in Forwarding mode?

    Older version of pfSense were using the DNS Forwarder, so you needed to specify DNS Servers in General config. With pfsense 2.2+, the default is the DNS resolver (unbound).

    Leave the DNS Server lines blank, disable DNS Resolver Forwarding mode, then unbound will contact the root DNS servers and provide service to your FW and LAN.



  • Hey thanks for your reply.

    Yes I have the resolver in forwarding mode so I can more easily try to control its traffic. If I had to try and route all the origin servers on the net a specific way it's be impossible, but in forwarding mode I can set the static routes you see above.

    However, I'm not getting the expected behavior as you can see!


  • LAYER 8 Global Moderator

    "If I had to try and route all the origin servers on the net a specific way it's be impossible"

    What like out your vpn??  Click done.. Policy route, dest port 53 tcp/udp use vpn gateway..

    But why would you even need to do that, just set the resolve to only use your vpn interface for queries, etc.



  • Hey thanks for your reply.

    I do have only the WAN interface selected for outbound DNS queries in the DNS Resolver config as you can see. Despite this enabling the VPN interface slows queries down as I mentioned. Were you referring to a different setting?



  • I see your point about the route – I'll try that. =)


Log in to reply