Install the UNIFI controller on pfsense 2.3.2



  • Hi Guys!

    I have a pfsense2.3.2 platform. I would like to me UNIFI controller installing for him.

    I find a guide: http://www.robpeck.com/2015/03/installing-the-ubiquiti-unifi-controller-software-on-pfsense-2.2/ - but this is not working! :(

    I can not do the first step, if i tyeing that: "pkg install unzip", than here is the result:

    [2.3.2-RELEASE][admin@TITAN.gyore-net]/root: pkg install unzip
    Updating pfSense-core repository catalogue…
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    pkg: No packages available to install matching 'unzip' have been found in the repositories

    What do i wrong?

    I tried this:
    [2.3.2-RELEASE][admin@TITAN.gyore-net]/root: pkg_add -r unzip
    pkg_add: Command not found.
    [2.3.2-RELEASE][admin@TITAN.gyore-net]/root:

    Thanks a lot!



  • others might be willing to aid you in your quest, i'm not.

    i've read a lot of posts here and there about this very thing … its a shitfest of workaround to get it working; its more then likely to break after an update ; goto 1
    i see no reason to go through all that shit ... just put it on a different device


  • Rebel Alliance Global Moderator

    Agreed this is pointless..  Run it on a vm, run it on their little cloudkey, run it in the cloud..  Just no point to messing with the pfsense install to try and get this to run.  If you could get signoff from the developers that this would be fine then ok..

    Now that they have really dropped support or suggestion that you run a wifi card in pfsense you can not longer purchase from their store appliances with wifi cards added and they suggest external AP maybe they would think about doing such a thing.. But I wouldn't hold my breath ;)

    If you want to run multiple things on 1 piece of hardware - then run VM…  I run pfsense on my esxi host, and then I have another vm for my controller, have another for my nas ;)  Which is the other thing people want to run on pfsense..