Switching from static to dhcp - could not get lease until reboot.



  • I am troubleshooting some wi-fi calling stuff and tried deleting the static record for the device to get a leased IP.

    No matter what I did the device would keep getting the reserved ip outside the dhcp scope.

    I put in a static address in the device and it could pass traffic just not get the address from the server.

    Worked fine after a reboot.

    Just FYI if anyone comes searching.


  • Rebel Alliance Global Moderator

    So did you delete the actual lease on the dhcp server, or have the client release it and then get a new one?

    I just recently removed a reservation for a machine to test that secondary pools were not handing out different info in that pool.  And to test that I wanted to put my machine in a 2nd pool.

    I removed the reservation I had.  Created a deny for its mac in the first pool.  I then release the reservation on the client, did a ipconfig /renew on the client and bing bang zoom got IP from the 2nd pool.  And as I found after verification that yup in dead extra pool info was not being handed out that there was a bug already entered for that very thing.

    You need to make sure there are no leases on the server for that client to renew if you want to have it get a new lease or use a reservation, etc or not use a removed reservation.