Amazon Echo suddenly blocked



  • My Amazon Echo Tap has worked fine for several months.  Suddenly this weekend it started saying that it could not connect to the internet.  All of my other wired and WiFi devices continued to work perfectly.  I tried:

    • Restarting the Echo

    • Restarting my WiFi access point (An Apple Airport Express in bridge mode)

    • Resetting the Echo to factory defaults

    • Resetting the WiFi access point to factory defaults

    None of that helped.  I finally tried restarting my pfSense router (10.3-RELEASE-p5), and that fixed it.

    Now my question is: why was pfSense blocking my Echo?  Looking through the logs I did not see anything helpful, but I may not have recognized the issue.

    I adding a firewall rule for traffic from the Echo's IP address, which does not block traffic, but logs it, which results in messages like:

    X Sep 19 12:01:43 LAN 10.0.5.18:33202 72.21.215.34:443 TCP:A

    Since rebooting pfSense fixed the problem, though, I don't expect it to be a firewall rule.  It is more likely to be a state table issue, right?

    Dashboard shows:

    
    State table size    0% (443/5000000)
    MBUF Usage          4% (36700/1000000)
    
    

    Is there something specific I should be looking for in the state table to identify a problem like this?  Is there any configuration steps I should take to help identify the issue?

    TIA!


  • LAYER 8 Global Moderator

    Well that is an out of state packet.. If your device wants to create a connection it has to send a Syn not an Ack..



  • Any time things are working great and then suddenly stop, I look for an IDS like Snort or pfBlocker. Something may have tripped a trigger and it added a rule to block the "offender".



  • Since rebooting it, fixed it for now, I will wait until it happens again, and try to get useful information out of the logs.

    Thank you for the comments.


  • LAYER 8 Global Moderator

    Rebooting what psense or the echo?

    Your state tables were not even close to being an issue.  So your not using any ids/ips package?



  • I've been having the same issues.  Did you ever resolve it?


Log in to reply