502+504 nginx + openvpn problem



  • Tirst off, i'm far from an expert and i know that there are numerous posts about about this.

    I've tried pretty much every fix i could find;
    Removed the openvpn widget
    Disabled https to connect only through http
    Connected to the console and ran 16+11 options
    Upgraded to 2.3.2
    Rebooted pfsense

    Problem is still there, trying to get to the webconsole takes forever. Sometimes i do get the page that i want and sometimes i get a gateway timeout.

    Here's how the pfsense is configured;

    Xen server with lan and vlan 835 for the wan. (ISP Orange in France)
    Fiber comes into the building to a converter to RJ45 which is in turn connected to the xenserver on the wan nic (vlan 835)
    Pfsense Wan connects through PPOe with dynamic address.
    Lan nic is connected to a switch where my computers are connected (DHCP)
    There's an openvpn tunnel from that office to the main office and both networks can talk to each other.

    Everything was working fine for over a week and all of a sudden we noticed that the interoffice vpn was down.

    Nginx.log
    Sep 21 02:58:49 su-fwl-fr su-fwl-fr.360-innovations.fr nginx: 2016/09/21 02:58:49 [crit] 43787#100104: *514 connect() to unix:/var/run/php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: 192.168.185.31, server: , request: "GET /getstats.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm.socket:", host: "192.168.185.1", referrer: "http://192.168.185.1/"
    Sep 21 02:58:49 su-fwl-fr su-fwl-fr.360-innovations.fr nginx: 192.168.185.31 - - [21/Sep/2016:02:58:49 +0200] "GET /getstats.php HTTP/1.1" 502 568 "http://192.168.185.1/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36"
    Sep 21 02:58:49 su-fwl-fr su-fwl-fr.360-innovations.fr nginx: 2016/09/21 02:58:49 [crit] 43787#100104: *512 connect() to unix:/var/run/php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: 192.168.185.31, server: , request: "GET /getstats.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm.socket:", host: "192.168.185.1", referrer: "http://192.168.185.1/"
    Sep 21 02:58:49 su-fwl-fr su-fwl-fr.360-innovations.fr nginx: 192.168.185.31 - - [21/Sep/2016:02:58:49 +0200] "GET /getstats.php HTTP/1.1" 502 568 "http://192.168.185.1/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36"
    Sep 21 02:58:49 su-fwl-fr su-fwl-fr.360-innovations.fr nginx: 2016/09/21 02:58:49 [crit] 43787#100104: *513 connect() to unix:/var/run/php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: 192.168.185.31, server: , request: "GET /getstats.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm.socket:", host: "192.168.185.1", referrer: "http://192.168.185.1/"
    Sep 21 02:58:49 su-fwl-fr su-fwl-fr.360-innovations.fr nginx: 192.168.185.31 - - [21/Sep/2016:02:58:49 +0200] "GET /getstats.php HTTP/1.1" 502 568 "http://192.168.185.1/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36"

    Nginx-error.log

    2016/09/21 03:55:45 [crit] 38750#100084: *162 connect() to unix:/var/run/php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: 192.168.185.31, server: , request: "GET /getstats.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm.socket:", host: "192.168.185.1", referrer: "http://192.168.185.1/"
    2016/09/21 03:55:45 [crit] 38750#100084: *164 connect() to unix:/var/run/php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: 192.168.185.31, server: , request: "GET /getstats.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm.socket:", host: "192.168.185.1", referrer: "http://192.168.185.1/"
    2016/09/21 03:55:45 [crit] 38750#100084: *154 connect() to unix:/var/run/php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: 192.168.185.31, server: , request: "GET /getstats.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm.socket:", host: "192.168.185.1", referrer: "http://192.168.185.1/"
    2016/09/21 03:55:45 [crit] 38750#100084: *156 connect() to unix:/var/run/php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: 192.168.185.31, server: , request: "GET /getstats.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm.socket:", host: "192.168.185.1", referrer: "http://192.168.185.1/"
    2016/09/21 03:55:45 [crit] 38750#100084: *158 connect() to unix:/var/run/php-fpm.socket failed (2: No such file or directory) while connecting to upstream, client: 192.168.185.31, server: , request: "GET /getstats.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm.socket:", host: "192.168.185.1", referrer: "http://192.168.185.1/"

    Openvpn.log

    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: MULTI: REAP range 144 -> 160
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: MANAGEMENT: Client connected from /var/etc/openvpn/server2.sock
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: SCHEDULE: schedule_find_least NULL
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: PO_CTL rwflags=0x0001 ev=6 arg=0x00693720
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: PO_CTL rwflags=0x0001 ev=7 arg=0x00692584
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: PO_CTL rwflags=0x0002 ev=8 arg=0x00692588
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: I/O WAIT TR|Tw|SR|Sw [10/0]
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: PO_WAIT[2,0] fd=8 rev=0x00000004 rwflags=0x0002 arg=0x00692588
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]:  event_wait returned 1
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: I/O WAIT status=0x0080
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: SCHEDULE: schedule_find_least NULL
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: PO_CTL rwflags=0x0001 ev=6 arg=0x00693720
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: PO_CTL rwflags=0x0001 ev=7 arg=0x00692584
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: PO_CTL rwflags=0x0001 ev=8 arg=0x00692588
    Sep 21 14:10:01 su-fwl-fr openvpn[19926]: I/O WAIT TR|Tw|SR|Sw [10/0]

    Internet and lan access works fine, only Openvpn and the fact that the webgui is very flaky.


Log in to reply