IP Monitor offline on USB LTE modem gateway



  • Im trying to have a multiwan setup that will have WAN = comcast and WWAN = ATT ZTE MF923 (https://www.att.com/support_static_files/manuals/ATT_Velocity_MF923.pdf) via USB. The MF923 was assigned as a interface ue0 and pulled a 192.168.1.52 and gateway of 192.168.1.1 from the devices dhcp server, I have internet access . I tried to find a way to set it to bridged/IP pass-through mode to pull the external IP but have been unsuccessful. So I just put the 192.168.1.52 ip in DMZ on the device to prevent any firewalling by the MF923.

    The issues im having to configure load balancing & failover is that the IP monitor on WAN (comcast) works fine with google dns 8.8.8.8, but show offline on the WWAN with 8.8.4.4. I can ping 8.8.4.4 from the WWAN in the gui, on the lan when using the MF923 exclusively for internet access so im assuming the gateway can respond to pings. WWAN will show online if the monitor ip is set to 192.168.1.1 (gateway ip).

    Anyone have a idea how to get ip monitoring working on this interface?

    I have attached some screenshots of my config. Please note that right now the WAN (comcast) will show an interal ip as I am configuring it behind another router, once deployed it will have a public ip.

    edit
    I also have upped the payload to something greater than 0 with no luck














  • Im still having this issue, also it seems the USB modem is not recognized as a WAN interface, no dns servers for this interface under status > interfaces. USB interface does not show up in traffic shaping either.

    How do I get pfsense to treat this a WAN interface?



  • Can anyone please help me?



  • I just now got a LB2120 LTE modem plugged into OPT1with the same scenario. Gateway is online for main ISP WAN but offline for LTE WAN2. I can place in load balancing with both on Tier1 and WAN2 pulls data, I can connect it to the WAN by itself and it works just fine however it always is stated as the gateway offline. Have you by chance found a solution to your problem or an adjustment to the gateway monitor?

    UPDATE:
    First off, just figured out that LTE networks only use carrier grade NAT which means even if you place your LTE modem in bridged mode, you're still in their network and not truly going to pull a public IP. Ugh. Their network is an IPv6 with IPv4 network translation. I do get a IPv6 with some configuring but without majorly adjusting settings within pfSense and I need IPv4 anyway.

    Now to answer your question, since we're still in a carrier grade NAT even in bridged mode, pfSense will say offline. Since the LTE modem is the failover and if neither WAN or WAN2 work then I'm toast I just set the WAN2 to not be monitored and failover works. Go to:

    System -> Routing -> Gateways and edit WAN2 gateway and next to Gateway Monitoring check to disable.


Log in to reply