Can someone look at my Traffic Shaping configuration



  • Hi

    Using beta3, I have following environment :

    Download Speed: 6144 kbps
    Uppload Speed: 735 kbps

    I have some computer in my LAN, one has the IP 192.168.10.15
    I want that this computer have low priority and other computers High priority

    I attache my configuration in this message.
    Can someone look at it and tell me why my configuration doesn't work ?

    [Working TrafficShaper Backup.xml.txt](/public/imported_attachments/1/Working TrafficShaper Backup.xml.txt)



  • OK, well from some test and research I have done priority keyword doesn't have any effect on the queues. So from the values I'm looking at in your config all the queues seem to be on par in terms of priority. I know it sounds weird but trust me the realtime value is what u really want to play with. Try giving  queue HighUpp_WAN and HighDown_LAN a higher realtime value to increase the delay priority on the queues and a higher linkshare value to give them more bandwidth. Set a linkshare value of 2k (m2 field) on those queues it should give them 66% of the bandwidth (worked out as a ratio) if both the high and low queues compete for it. Also as mentioned setting the realtime value higher should give those queues more delay priority.. by how much? not sure it varies but the value you set is guaranteed and cannot be over 80% of the interface bandwidth. 10% - 25% of the bandwidth sound like reasonable figures. Additionally you may want to look at http://wiki.pfsense.com/wikka.php?wakka=HFSCBandwidthShapingNotes



  • Thanks of taking time for testing my scenario.

    I did as you suggested without any good result.
    However, it seems that I narrow the problem to the "Rules" and not the "Queues"
    When looking at "Status:Queues", I never see any activities for queues HighDown_LAN and HighUpp_WAN

    Dose the rules based on IP number really work ?



  • Yes, they do. Keep in mind that you need to reset states to apply a new ruleset to already existing connections.



  • It seams that I can't make the rules work.
    voyager is  alias for IP 192.168.10.15
    When I ftp diffrent WAN server from computers inside WAN other than voyager, and look at the "Status:Queues", I can't see any activities for queues HighUpp_WAN and HighDown_LAN
    I also tried to reset the states.
    What do I do for wrong, this is my rules :





  • you inbound and outbound queues are suppose to be the other way around..

    for example

    LAN>WAN * voyager * LowDown_LAN/LowUpp_WAN



  • Can't do that, get lots of error when I do that,

    To make it easier for understand, I changed back the name of my queues to the orginal name and sending the picture
    and my config file agian in this message.
    What do you think I should do now ?




    TrafficShaper.xml.txt


Log in to reply